summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-08 00:15:26 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-08 00:15:26 +0100
commit2f4fbe1cb36253cabf2afea38f6674c2f88cc191 (patch)
tree4e8b02449b4718b7de909a42e502215e0d492439 /gnu/packages/guile.scm
parent461572cca8655d0a7590309f557149e8d3405932 (diff)
downloadguix-2f4fbe1cb36253cabf2afea38f6674c2f88cc191.tar.gz
gnu: guile-1.8: Patch `ice-9/popen.scm'.
* gnu/packages/guile.scm (guile-1.8): Rename `patch-loader-search-path'
  to `patch-stuff'; patch `ice-9/popen.scm'.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index a769e7eac9..e36c0c2a2e 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -58,17 +58,21 @@
                 ;; Insert a phase before `configure' to patch things up.
                 #:phases (alist-cons-before
                            'configure
-                           'patch-loader-search-path
+                           'patch-stuff
                            (lambda* (#:key outputs #:allow-other-keys)
                              ;; Add a call to `lt_dladdsearchdir' so that
                              ;; `libguile-readline.so' & co. are in the
                              ;; loader's search path.
                              (substitute* "libguile/dynl.c"
-                                          (("lt_dlinit.*$" match)
-                                           (format #f
-                                                   "  ~a~%  lt_dladdsearchdir(\"~a/lib\");~%"
-                                                   match
-                                                   (assoc-ref outputs "out")))))
+                               (("lt_dlinit.*$" match)
+                                (format #f
+                                        "  ~a~%  lt_dladdsearchdir(\"~a/lib\");~%"
+                                        match
+                                        (assoc-ref outputs "out"))))
+
+                             ;; The usual /bin/sh...
+                             (substitute* "ice-9/popen.scm"
+                               (("/bin/sh") (which "sh"))))
                            %standard-phases)))
    (inputs `(("patch/snarf" ,(search-patch "guile-1.8-cpp-4.5.patch"))
              ("gawk" ,gawk)