summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-06-02 15:34:36 +0200
committerLudovic Courtès <ludo@gnu.org>2017-06-02 17:22:06 +0200
commitbaf549df14c6d4a63bfbd0054b865446a97e872a (patch)
tree4574769df30574538749fd4826ca9b14b7f23b6c /gnu/packages/guile.scm
parent4cc80c946b6915db450007c7c648082c27a368c9 (diff)
downloadguix-baf549df14c6d4a63bfbd0054b865446a97e872a.tar.gz
gnu: guile: Depend on 'bash-minimal' rather than 'bash'.
* gnu/packages/guile.scm (guile-2.0)[inputs]: Depend on BASH-MINIMAL
instead of BASH.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index bb34063463..bcfbe65aec 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -153,7 +153,11 @@ without requiring the source code to be rewritten.")
    (inputs `(("libffi" ,libffi)
              ("readline" ,readline)
              ,@(libiconv-if-needed)
-             ,@(if (target-mingw?) '() `(("bash" ,bash)))))
+
+             ;; We need Bash when cross-compiling because some of the scripts
+             ;; in bin/ refer to it.  Use 'bash-minimal' because we don't need
+             ;; an interactive Bash with Readline and all.
+             ,@(if (target-mingw?) '() `(("bash" ,bash-minimal)))))
    (propagated-inputs
     `( ;; These ones aren't normally needed here, but since `libguile-2.0.la'
        ;; reads `-lltdl -lunistring', adding them here will add the needed