summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-05 19:15:39 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-05 19:15:39 +0200
commitcf6db76d2af2f287f12928df160447ab4165b3e5 (patch)
tree49a1309c0e04c00090ab106f7ae3495a6da328c1 /gnu/packages/guile.scm
parente65b2181e8b436278e3dd0b405602a400fbd0a75 (diff)
parenta6798218bea0d6b2df598042d1ced29f74bb4250 (diff)
downloadguix-cf6db76d2af2f287f12928df160447ab4165b3e5.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 39d1ebe681..83cb75d315 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -287,8 +287,8 @@ without requiring the source code to be rewritten.")
 
 (define-public guile-next
   ;; This is the upcoming Guile 3.0, with JIT support.
-  (let ((commit "a74b4a45fab1a78e34954bce5f031e8a9765f827")
-        (revision "0"))
+  (let ((commit "6f3357b0df64c4be17e72079864c09a542f1c779")
+        (revision "1"))
     (package
       (inherit guile-2.2)
       (name "guile-next")
@@ -300,7 +300,7 @@ without requiring the source code to be rewritten.")
                       (commit commit)))
                 (sha256
                  (base32
-                  "0kq6mabv7j4gdlwmpz3iaddv98sc7awkl2358sg8j50sg10yw8nx"))
+                  "1c2xy5cflg0hws48914rz3z8mdmf8w3lblfic0kxnymcmdv9cbhv"))
                 (file-name (git-file-name name version))))
       (native-inputs
        `(("autoconf", autoconf)
@@ -324,7 +324,15 @@ without requiring the source code to be rewritten.")
                (lambda _
                  ;; Remove this test that's bound to fail.
                  (delete-file "test-suite/tests/version.test")
-                 #t)))))))))
+                 #t))))))
+      (native-search-paths
+       (list (search-path-specification
+              (variable "GUILE_LOAD_PATH")
+              (files '("share/guile/site/3.0")))
+             (search-path-specification
+              (variable "GUILE_LOAD_COMPILED_PATH")
+              (files '("lib/guile/3.0/site-ccache"
+                       "share/guile/site/3.0"))))))))
 
 (define (make-guile-readline guile)
   (package