summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-08-28 14:22:15 -0400
committerMark H Weaver <mhw@netris.org>2014-08-28 14:22:15 -0400
commitc00a9fbfef75d2fc08485f8158ec331bfa99d5ec (patch)
tree4737817ee787c4ec8222ea13d3cfecb2ac98b673 /gnu/packages/guile.scm
parent83291101c39c1cd1bf472280c24ad68d94248c2e (diff)
parentdd16424466196616b99c13526537a89aaee27f88 (diff)
downloadguix-c00a9fbfef75d2fc08485f8158ec331bfa99d5ec.tar.gz
Merge branch 'master' into core-updates
Conflicts:
	gnu/packages/base.scm
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 064c859e69..1169158113 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -34,6 +34,7 @@
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages ed)
   #:use-module (gnu packages which)
+  #:use-module (gnu packages gtk)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
@@ -355,4 +356,35 @@ http:://json.org specification. These are the main features:
 - Allows JSON pretty printing.")
     (license lgpl3+)))
 
+(define-public guile-charting
+  (package
+    (name "guile-charting")
+    (version "0.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://wingolog.org/pub/guile-charting/"
+                                  "guile-charting-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1l8xcqq4cp67jzxnmf07ivsgq23mfmi00zz1s8bnv2zkb0ab9475"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; Remove dependency from guile-charting.texi to
+               ;; guile-chartingscmfiles to avoid rebuild the doc (which is
+               ;; unnecessary and fails with "failed to match any pattern in
+               ;; form define-macro-with-docs" as of Guile 2.0.11.)
+               '(substitute* "doc/Makefile.in"
+                  (("^(.+):(.*) \\$\\(doc\\)scmfiles(.*$)" _ target dep1 dep2)
+                   (string-append target ":" dep1 " " dep2 "\n"))))))
+    (build-system gnu-build-system)
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("guile" ,guile-2.0)
+              ("guile-cairo" ,guile-cairo)))
+    (home-page "http://wingolog.org/software/guile-charting/")
+    (synopsis "Create charts and graphs in Guile")
+    (description
+     "Guile-Charting is a Guile Scheme library to create bar charts and graphs
+using the Cairo drawing library.")
+    (license lgpl2.1+)))
+
 ;;; guile.scm ends here