summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-01-16 16:41:59 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-16 18:30:57 +0100
commite7921d5ecb9b9615396e5bbd286f132d97d016cc (patch)
treeff98fb6dbd876685aa7274f3df07c705df895862 /gnu/packages/guile.scm
parent47212fc763788660ff9051ccee1f6fa8a0db7bdd (diff)
downloadguix-e7921d5ecb9b9615396e5bbd286f132d97d016cc.tar.gz
gnu: guile: Add 3.0.0.
* gnu/packages/guile.scm (guile-3.0): New variable.
(guile-next): Turn into an alias for GUILE-3.0.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 8d3f43e3f7..e940d38b17 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -283,19 +283,19 @@ without requiring the source code to be rewritten.")
               (base32
                "07p3g0v2ba2vlfbfidqzlgbhnzdx46wh2rgc5gszq1mjyx5bks6r"))))))
 
-(define-public guile-next
-  ;; This is the upcoming Guile 3.0, with JIT support.
+(define-public guile-3.0
+  ;; This is the latest Guile stable version.
   (package
     (inherit guile-2.2)
-    (name "guile-next")
-    (version "2.9.9")
+    (name "guile-next")                           ;to be renamed to "guile"
+    (version "3.0.0")
     (source (origin
               (inherit (package-source guile-2.2))
-              (uri (string-append "ftp://alpha.gnu.org/gnu/guile/guile-"
+              (uri (string-append "ftp://ftp.gnu.org/gnu/guile/guile-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "0s99zzdzj29fb42q5fwn7vqg9k7y9ppq9vkv4p39zr93z8694wdz"))))
+                "0x8ca6q1qdmk29lh12gj6ngvgn7kp79w42rxfgwrpxm9jmjqs4y9"))))
     (native-search-paths
      (list (search-path-specification
             (variable "GUILE_LOAD_PATH")
@@ -303,9 +303,9 @@ without requiring the source code to be rewritten.")
            (search-path-specification
             (variable "GUILE_LOAD_COMPILED_PATH")
             (files '("lib/guile/3.0/site-ccache"
-                     "share/guile/site/3.0")))))
-    (properties '((ftp-server . "alpha.gnu.org")
-                  (upstream-name . "guile")))))
+                     "share/guile/site/3.0")))))))
+
+(define-public guile-next guile-3.0)
 
 (define* (make-guile-readline guile #:optional (name "guile-readline"))
   (package