summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-16 04:20:44 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-16 11:11:40 +0100
commit340978d7b054dcde6c3334267b40a8293eb0ce85 (patch)
tree173a86b7c1225f74771a1783380689291ed3d955 /gnu/packages/guile.scm
parent10cac630c249dcca0e43e0b3e1cbd28043796eb9 (diff)
downloadguix-340978d7b054dcde6c3334267b40a8293eb0ce85.tar.gz
gnu: Use HTTPS for supported nongnu.org home pages.
* gnu/packages/acl.scm (acl)[home-page]: Use HTTPS.
* gnu/packages/admin.scm (dmidecode)[home-page]: Likewise.
* gnu/packages/attr.scm (attr)[home-page]: Likewise.
* gnu/packages/audio.scm (lash)[home-page]: Likewise.
* gnu/packages/avr.scm (avr-libc)[home-page]: Likewise.
* gnu/packages/backup.scm (rdiff-backup, libchop)[home-page]: Likewise.
* gnu/packages/compression.scm (fastjar, lzip, lziprecover, atool)
(lunzip, clzip, lzlib, plzip)[home-page]: Likewise.
* gnu/packages/emacs.scm (geiser, bbdb, m17n-lib, m17n-lib)[home-page]:
Likewise.
* gnu/packages/flashing-tools.scm (avrdude)[home-page]: Likewise.
* gnu/packages/fontutils.scm (libotf)[home-page]: Likewise.
* gnu/packages/game-development.scm (gzochi)[home-page]: Likewise.
* gnu/packages/games.scm (enigma)[home-page]: Likewise.
* gnu/packages/gsasl.scm (libntlm)[home-page]: Likewise.
* gnu/packages/gtk.scm (guile-cairo)[home-page]: Likewise.
* gnu/packages/guile.scm (guile-reader, guile-lib, guile-json)
(guile-redis, g-wrap)[home-page]: Likewise.
* gnu/packages/libunwind.scm (libunwind)[home-page]: Likewise.
* gnu/packages/lout.scm (lout)[home-page]: Likewise.
* gnu/packages/mpd.scm (sonata)[home-page]: Likewise.
* gnu/packages/networking.scm (quagga)[home-page]: Likewise.
* gnu/packages/ratpoison.scm (ratpoison)[home-page]: Likewise.
* gnu/packages/skribilo.scm (skribilo)[home-page]: Likewise.
* gnu/packages/telephony.scm (exosip)[home-page]: Likewise.
* gnu/packages/texinfo.scm (texi2html)[home-page]: Likewise.
* gnu/packages/xdisorg.scm (xbindkeys)[home-page]: Likewise.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 7c03a9c86b..9005779826 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -528,7 +528,7 @@ document syntax.
 Guile-Reader’s approach is similar to Common Lisp’s “read table”, but
 hopefully more powerful and flexible (for instance, one may instantiate as
 many readers as needed).")
-    (home-page "http://www.nongnu.org/guile-reader/")
+    (home-page "https://www.nongnu.org/guile-reader/")
     (license license:gpl3+)))
 
 (define-public guile2.0-reader
@@ -739,7 +739,7 @@ $(libdir)/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n"))
              #t)))))
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs `(("guile" ,guile-2.2)))
-    (home-page "http://www.nongnu.org/guile-lib/")
+    (home-page "https://www.nongnu.org/guile-lib/")
     (synopsis "Collection of useful Guile Scheme modules")
     (description
      "Guile-Lib is intended as an accumulation place for pure-scheme Guile
@@ -782,7 +782,7 @@ for Guile\".")
                      (string-append all "/@GUILE_EFFECTIVE_VERSION@")))))))
     (build-system gnu-build-system)
     (native-inputs `(("guile" ,guile-2.2)))
-    (home-page "http://savannah.nongnu.org/projects/guile-json/")
+    (home-page "https://savannah.nongnu.org/projects/guile-json/")
     (synopsis "JSON module for Guile")
     (description
      "Guile-JSON supports parsing and building JSON documents according to the
@@ -1290,7 +1290,7 @@ above command-line parameters.")
     (build-system gnu-build-system)
     (native-inputs
      `(("guile" ,guile-2.0)))
-    (home-page "http://savannah.nongnu.org/projects/guile-redis/")
+    (home-page "https://savannah.nongnu.org/projects/guile-redis/")
     (synopsis "Redis client library for Guile")
     (description "Guile-redis provides a Scheme interface to the Redis
 key-value cache and store.")
@@ -1460,7 +1460,7 @@ wrappers for inter-language calls.  It currently only supports generating Guile
 wrappers for C functions.  Given a definition of the types and prototypes for
 a given C interface, G-Wrap will automatically generate the C code that
 provides access to that interface and its types from the Scheme level.")
-    (home-page "http://www.nongnu.org/g-wrap/index.html")
+    (home-page "https://www.nongnu.org/g-wrap/index.html")
     (license license:lgpl2.1+)))
 
 (define-public guile-dbi