summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-11-18 10:37:46 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-18 18:28:02 +0100
commit8134dc1f74c2df2d42e1510fd3ac35234a4d89df (patch)
tree9886d39a0e57a7099e0f99f34229840fdae8e544 /gnu/packages/guile.scm
parent651049789fe84e1c4642d218aab261258fbd7834 (diff)
downloadguix-8134dc1f74c2df2d42e1510fd3ac35234a4d89df.tar.gz
gnu: guile@2.0.13: Fix non-determinism issue in REPL server test.
* gnu/packages/patches/guile-repl-server-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/guile.scm (guile-2.0.13)[source]: Use it.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 3f45b29038..4572544ec3 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -217,7 +217,8 @@ without requiring the source code to be rewritten.")
                                   ".tar.xz"))
               (sha256
                (base32
-                "12yqkr974y91ylgw6jnmci2v90i90s7h9vxa4zk0sai8vjnz4i1p"))))))
+                "12yqkr974y91ylgw6jnmci2v90i90s7h9vxa4zk0sai8vjnz4i1p"))
+              (patches (search-patches "guile-repl-server-test.patch"))))))
 
 (define-public guile-next
   (package (inherit guile-2.0)