summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2021-12-12 11:57:45 -0500
committerTimothy Sample <samplet@ngyro.com>2021-12-22 11:35:06 -0500
commiteaa7ead41c9568d00124d852835569b75c3333af (patch)
tree5396d98430414963da829836f5a6f1708c6adc26 /gnu/packages/guile.scm
parent0f859051dc0d03b66d6cd65e52c5fc61aa189b8b (diff)
downloadguix-eaa7ead41c9568d00124d852835569b75c3333af.tar.gz
gnu: Add guile-lzma.
* gnu/packages/guile.scm (guile-lzma): New variable.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 28887dd69f..8a0d800d40 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -17,6 +17,7 @@
 ;;; Copyright © 2019 Taylan Kammer <taylan.kammer@gmail.com>
 ;;; Copyright © 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Timothy Sample <samplet@ngyro.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -904,4 +905,27 @@ pure Scheme by using Guile's foreign function interface.")
 compression library.")
     (license license:gpl3+)))
 
+(define-public guile-lzma
+  (package
+    (name "guile-lzma")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://files.ngyro.com/guile-lzma/guile-lzma-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "1f7pd3frckpwsi5p0bln4wf8xy41x0szlpy273phjdmjacw69hzb"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     (list autoconf automake guile-3.0 guile-bytestructures pkg-config))
+    (inputs (list guile-3.0 xz))
+    (propagated-inputs (list guile-bytestructures))
+    (home-page "https://ngyro.com/software/guile-lzma.html")
+    (synopsis "Guile bindings for liblzma (XZ)")
+    (description "Guile-LZMA is a Guile wrapper for the liblzma (XZ)
+library.  It exposes an interface similar to other Guile compression
+libraries, like Guile-zlib.")
+    (license license:gpl3+)))
+
 ;;; guile.scm ends here