summary refs log tree commit diff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-21 21:38:19 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-21 21:38:19 -0400
commit49b350fafc2c3ea1db66461b73d4e304cd13ec92 (patch)
tree9b9b1a4a383b5175241ae6b91b83de0590f13983 /gnu/packages/hardware.scm
parent03b5668a035ba96c9690476078c5ee1d5793f3e2 (diff)
parente584a093f943be216fdc93895281fde835836b8d (diff)
downloadguix-49b350fafc2c3ea1db66461b73d4e304cd13ec92.tar.gz
Merge branch 'master' into staging.
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index a3ce90f75e..60b9a9f17b 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -12,6 +12,7 @@
 ;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
 ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2022 Marcel Kupiec <formbi@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -46,6 +47,7 @@
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages lxqt)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages openldap)
   #:use-module (gnu packages pciutils)
@@ -53,6 +55,7 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages polkit)
   #:use-module (gnu packages protobuf)
+  #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
@@ -180,6 +183,62 @@ It can be used to generate a system overview log which can be later used for
 support.")
     (license license:gpl2+)))
 
+(define-public ckb-next
+  (let ((commit "967f44018a9d46efa7203fad38518e9381eba0f3")
+        (revision "0"))
+    (package
+      (name "ckb-next")
+      (version (git-version "0.4.4" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/ckb-next/ckb-next")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "0bfpah0zgmyhbi6payymr3p98nfnwqr2xqxgkyzvccz72z246316"))
+                (file-name (git-file-name name version))))
+      (build-system cmake-build-system)
+      (arguments
+       `(#:modules ((guix build cmake-build-system) (guix build qt-utils)
+                    (guix build utils))
+         #:imported-modules (,@%cmake-build-system-modules
+                             (guix build qt-utils))
+         #:tests? #f
+         #:phases
+         (modify-phases %standard-phases
+           (add-before 'build 'patch-lib-udev
+             (lambda* (#:key inputs outputs #:allow-other-keys)
+               (substitute* "src/daemon/cmake_install.cmake"
+                 (("/lib/udev")
+                  (string-append (assoc-ref outputs "out")
+                                 "/lib/udev")))))
+           (add-after 'install 'wrap-qt
+             (lambda* (#:key inputs outputs #:allow-other-keys)
+               (let ((out (assoc-ref outputs "out")))
+                 (wrap-qt-program "ckb-next"
+                                  #:output out
+                                  #:inputs inputs)))))))
+      (native-inputs (list qttools pkg-config))
+      (inputs (list qtbase-5
+                    zlib
+                    libdbusmenu-qt
+                    quazip
+                    pulseaudio
+                    libxcb
+                    xcb-util-wm
+                    qtx11extras
+                    eudev
+                    bash-minimal))
+      (home-page "https://github.com/ckb-next/ckb-next")
+      (synopsis "Driver for Corsair keyboards and mice")
+      (description
+       "ckb-next is a driver for Corsair keyboards and mice.  It aims to bring
+the features of Corsair's proprietary software to Linux-based operating
+systems.  It already supports much of the same functionality, including full
+RGB animations.")
+      (license license:gpl2))))
+
 (define-public ddcutil
   (package
     (name "ddcutil")