summary refs log tree commit diff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-09-28 21:20:05 +0100
committerLudovic Courtès <ludo@gnu.org>2022-10-10 11:16:07 +0200
commit69598d84893669b0089309b9e5d967231cae84fa (patch)
tree1aafdbd8a4c450e953ccbfd9f162e4c9d3b45625 /gnu/packages/hardware.scm
parentf8bc5b13ad6b66f5efa4076495d11be7725f5279 (diff)
downloadguix-69598d84893669b0089309b9e5d967231cae84fa.tar.gz
gnu: Move libqb to high-availability.
* gnu/packages/hardware.scm (libqb): Move to high-availability.scm.
* gnu/packages/high-availability.scm: New file.
* gnu/local.mk: Add high-availability.scm to GNU_SYSTEM_MODULES list.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm28
1 files changed, 1 insertions, 27 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index d47be7a55d..41519440fd 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -56,6 +56,7 @@
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
+  #:use-module (gnu packages high-availability)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lxqt)
@@ -1117,33 +1118,6 @@ supported by the Linux kernel.")
 as the Pinebook Pro.")
       (license license:gpl2+))))
 
-(define-public libqb
-  (package
-    (name "libqb")
-    ;; NOTE: We are using a Release Candidate version (for 2.0) here because
-    ;; of the linker issues with the previous release.
-    (version "1.9.1")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/ClusterLabs/libqb/releases/download/v"
-                    version "/libqb-" version ".tar.xz"))
-              (sha256
-               (base32
-                "008vvw504kh40br5v2xkqavnp9vpmjvf768faqzv1d00fd53ingn"))))
-    (build-system gnu-build-system)
-    (native-inputs
-     (list pkg-config libxml2))
-    (home-page "https://clusterlabs.github.io/libqb/")
-    (synopsis "Library providing high performance logging, tracing, ipc, and poll")
-    (description "Libqb is a library with the primary purpose of providing
-high-performance, reusable features for client-server architecture, such as
-logging, tracing, inter-process communication (IPC), and polling.  Libqb is
-not intended to be an all-encompassing library, but instead provide focused
-APIs that are highly tuned for maximum performance for client-server
-applications.")
-    (license license:lgpl2.1)))
-
 (define-public usbguard
   (package
     (name "usbguard")