summary refs log tree commit diff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2020-05-07 11:16:51 +0200
committerBrice Waegeneire <brice@waegenei.re>2020-05-07 11:26:44 +0200
commitf96ddb60962703eaae5433399905b9d81a99ea13 (patch)
treef2a73c188dd2201234ba8d8e0d0faa9d94d82a69 /gnu/packages/hardware.scm
parentfebd19daaa857e5e0f633bc5127be1ee737e5847 (diff)
downloadguix-f96ddb60962703eaae5433399905b9d81a99ea13.tar.gz
gnu: usbguard: Fix warning about 'catch'.
* gnu/packages/hardware.scm (usbguard)[arguments]: Rename phase
'patch-makefile' to 'patch-build-scripts', patch 'Makefile.in' files
instead of 'Makefile.am' and fix 'catch' include path.
[native-inputs]: Remove 'autoconf' and 'automake'.
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 74fd282191..7ca565e17f 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -400,13 +400,16 @@ applications.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-after 'configure 'patch-makefile
-           (lambda _
+         (add-after 'unpack 'patch-build-scripts
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "configure"
+               (("/usr/include/catch")
+                (string-append (assoc-ref inputs "catch") "/include")))
              ;; Do not create log directory.
-             (substitute* "Makefile" ((".*/log/usbguard.*") ""))
+             (substitute* "Makefile.in" ((".*/log/usbguard.*") ""))
              ;; Disable LDAP tests: they use 'sudo'.
-             (substitute* "src/Tests/Makefile.am"
-               (("WITH_LDAP") "FALSE"))
+             (substitute* "src/Tests/Makefile.in"
+               (("\\$\\(am__append_2\\)") ""))
              #t))
          (add-after 'install 'delete-static-library
            (lambda* (#:key outputs #:allow-other-keys)
@@ -448,8 +451,6 @@ applications.")
        ("libqb" ,libqb)))
     (native-inputs
      `(("asciidoc" ,asciidoc)
-       ("autoconf" ,autoconf)
-       ("automake" ,automake)
        ("bash-completion" ,bash-completion)
        ("gdbus-codegen" ,glib "bin")
        ("umockdev" ,umockdev)