summary refs log tree commit diff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-09-28 15:45:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-09-28 15:45:48 +0300
commit9bd8e145500d8687bb240fb66691e00aa56f66a6 (patch)
tree34189f238489bca0ab844c30c0f5ec7439a8b0c1 /gnu/packages/haskell-apps.scm
parentc249927ebba47f9b199fdf8a88804a2c1713a097 (diff)
downloadguix-9bd8e145500d8687bb240fb66691e00aa56f66a6.tar.gz
gnu: git-annex: Update to 10.20220927.
* gnu/packages/haskell-apps.scm (git-annex): Update to 10.20220927.
[inputs]: Add ghc-clientsession, ghc-wai, ghc-wai-extra, ghc-warp,
ghc-warp-tls, ghc-yesod, ghc-yesod-core, ghc-yesod-form, and
ghc-yesod-static.
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 50380281d7..58a70dfa3a 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -304,14 +304,14 @@ to @code{cabal repl}).")
 (define-public git-annex
   (package
     (name "git-annex")
-    (version "10.20220822")
+    (version "10.20220927")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://hackage.haskell.org/package/"
                            "git-annex/git-annex-" version ".tar.gz"))
        (sha256
-        (base32 "1qv3cb7p2zyc5mpcr4nfgzdmswfny5jbimd2ip7ygh71jlahrbfc"))))
+        (base32 "1bqcaddw47g6i3z9g0iym5x7zy1q8fsirzqnjsa63n2bwm6zzplc"))))
     (build-system haskell-build-system)
     (arguments
      `(#:configure-flags
@@ -406,6 +406,7 @@ to @code{cabal repl}).")
            ghc-bloomfilter
            ghc-byteable
            ghc-case-insensitive
+           ghc-clientsession
            ghc-concurrent-output
            ghc-conduit
            ghc-connection
@@ -462,6 +463,14 @@ to @code{cabal repl}).")
            ghc-utf8-string
            ghc-uuid
            ghc-vector
+           ghc-wai
+           ghc-wai-extra
+           ghc-warp
+           ghc-warp-tls
+           ghc-yesod
+           ghc-yesod-core
+           ghc-yesod-form
+           ghc-yesod-static
            git
            rsync))
     (native-inputs