summary refs log tree commit diff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2020-05-22 14:12:50 -0400
committerLeo Famulari <leo@famulari.name>2020-05-22 18:53:47 -0400
commitf64a74dd6c69a0e404b40b7688cdcbcaf63fdf42 (patch)
tree960cb95896e7759cdca294c1c0b02230738f9714 /gnu/packages/haskell-apps.scm
parent595f30c0de09659d5aeaecfba7384b0c4e668b55 (diff)
downloadguix-f64a74dd6c69a0e404b40b7688cdcbcaf63fdf42.tar.gz
gnu: git-annex: Update to 8.20200522.
* gnu/packages/haskell-apps.scm (git-annex): Update to 8.20200522.
[source]: Remove patch that is now in a release.
* gnu/packages/patches/git-annex-S3v4.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index ecfe439c4b..3089c17145 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -37,7 +37,6 @@
   #:use-module (guix packages)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix build-system haskell)
-  #:use-module (gnu packages)
   #:use-module (gnu packages base)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages gl)
@@ -342,15 +341,14 @@ to @code{cabal repl}).")
 (define-public git-annex
   (package
     (name "git-annex")
-    (version "8.20200501")
+    (version "8.20200522")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://hackage.haskell.org/package/"
                            "git-annex/git-annex-" version ".tar.gz"))
-       (patches (search-patches "git-annex-S3v4.patch"))
        (sha256
-        (base32 "19rggaymvqy7r61n2rl2nigwdi2hzq5l1afcd5l0k1vbacwgq4jl"))))
+        (base32 "1v71k5k9mcj1nq4pb8apx99rgw2rmckr6yshhvjl1dr6j70d67x8"))))
     (build-system haskell-build-system)
     (arguments
      `(#:configure-flags