summary refs log tree commit diff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2019-07-21 15:50:58 -0400
committerMarius Bakke <mbakke@fastmail.com>2019-08-08 20:14:14 +0200
commita4a41a7ba8fbd3b9fe3bf3ee0a6f6da64ffed1f3 (patch)
tree97feff5a21fecce28a1b98b437f01f6a071f6eb8 /gnu/packages/haskell-apps.scm
parent3d45d8f14bea0468494442597e005c9a6b46155b (diff)
downloadguix-a4a41a7ba8fbd3b9fe3bf3ee0a6f6da64ffed1f3.tar.gz
gnu: git-annex: Update to 7.20190708.
* gnu/packages/haskell-apps.scm (git-annex): Update to 7.20190708.
[inputs]: Add new dependency, ghc-concurrent-output.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 818e691a6e..e77f6d113b 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -143,7 +143,7 @@ unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
 (define-public git-annex
   (package
     (name "git-annex")
-    (version "6.20180926")
+    (version "7.20190708")
     (source
      (origin
        (method url-fetch)
@@ -151,7 +151,7 @@ unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
                            "git-annex/git-annex-" version ".tar.gz"))
        (sha256
         (base32
-         "1251rj8h63y30sfqk0zh670yhz14p256y59n3590pg015pf3575d"))))
+         "18s563swrp8mx479995pdhhmn40y3xwlbm1z3w63qsnjqmj7zlij"))))
     (build-system haskell-build-system)
     (arguments
      `(#:configure-flags
@@ -219,6 +219,7 @@ unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
        ("ghc-bloomfilter" ,ghc-bloomfilter)
        ("ghc-byteable" ,ghc-byteable)
        ("ghc-case-insensitive" ,ghc-case-insensitive)
+       ("ghc-concurrent-output" ,ghc-concurrent-output)
        ("ghc-crypto-api" ,ghc-crypto-api)
        ("ghc-cryptonite" ,ghc-cryptonite)
        ("ghc-data-default" ,ghc-data-default)