summary refs log tree commit diff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-02-08 15:17:15 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-02-08 15:39:55 +0100
commita60448edcc85faa8b3cd4bd3ae8a336c842aad4d (patch)
treeb77060dd9ecaa27e60551688de35e24653909e22 /gnu/packages/haskell-check.scm
parente90a06fcc55b6bef68e8fed88eebed403058f55c (diff)
downloadguix-a60448edcc85faa8b3cd4bd3ae8a336c842aad4d.tar.gz
gnu: Add ghc-hspec-discover.
* gnu/packages/haskell-check.scm (ghc-hspec-discover): New variable.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index c6e89460ea..0dae620119 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -11,6 +11,7 @@
 ;;; Copyright © 2018 Tonton <tonton@riseup.net>
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
+;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -772,6 +773,29 @@ Haskell, inspired by the Ruby library RSpec.")
      "This package provides contributed Hspec extensions.")
     (license license:expat)))
 
+(define-public ghc-hspec-discover
+  (package
+    (name "ghc-hspec-discover")
+    (version "2.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/hspec-discover/"
+             "hspec-discover-" version ".tar.gz"))
+       (sha256
+        (base32 "0r47fm94wa6qrhp8cc1zzkjrxc32rnagfn9m9ga4dm6p6ydw4c8b"))))
+    (build-system haskell-build-system)
+    (native-inputs
+     `(("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-hspec-meta" ,ghc-hspec-meta)))
+    (home-page "http://hspec.github.io/")
+    (synopsis "Automatically discover and run Hspec tests")
+    (description
+     "Automatically discover and run Hspec tests.  See
+@url{http://hspec.github.io/hspec-discover.html}.")
+    (license license:expat)))
+
 (define-public ghc-hspec-expectations
   (package
     (name "ghc-hspec-expectations")