summary refs log tree commit diff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 10:22:19 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:13 -0500
commita777c69aaf6b89554550044b0b9ac6235d0e290b (patch)
tree474c214a0a4dd1e028e4bf70f0c332313c2698e3 /gnu/packages/haskell-check.scm
parent10650c441b4a555ad78b9fbcd328bc5cc5231f8e (diff)
downloadguix-a777c69aaf6b89554550044b0b9ac6235d0e290b.tar.gz
gnu: ghc-hspec-core: Update to 2.7.1.
* gnu/packages/haskell-check.scm (ghc-hspec-core): Update to 2.7.1.
[inputs]: Remove 'ghc-async' and add 'ghc-tf-random'.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index ba54b1378a..4d28ad9156 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -607,7 +607,7 @@ runs Hspec tests.")
 (define-public ghc-hspec-core
   (package
     (name "ghc-hspec-core")
-    (version "2.5.5")
+    (version "2.7.1")
     (source
      (origin
        (method url-fetch)
@@ -615,19 +615,19 @@ runs Hspec tests.")
                            "hspec-core-" version ".tar.gz"))
        (sha256
         (base32
-         "1vfrqlpn32s9wiykmkxbnrnd5p56yznw20pf8fwzw78ar4wpz55x"))))
+         "08vk8588lap00hsln8zl64dazbb28lzk4b4h5vnm7xvhg7r21k1c"))))
     (build-system haskell-build-system)
     (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
     (inputs
      `(("ghc-setenv" ,ghc-setenv)
        ("ghc-ansi-terminal" ,ghc-ansi-terminal)
-       ("ghc-async" ,ghc-async)
        ("ghc-clock" ,ghc-clock)
        ("ghc-quickcheck-io" ,ghc-quickcheck-io)
        ("ghc-hunit" ,ghc-hunit)
        ("ghc-quickcheck" ,ghc-quickcheck)
        ("ghc-hspec-expectations" ,ghc-hspec-expectations)
-       ("ghc-silently" ,ghc-silently)))
+       ("ghc-silently" ,ghc-silently)
+       ("ghc-tf-random" ,ghc-tf-random)))
     (home-page "https://hspec.github.io/")
     (synopsis "Testing framework for Haskell")
     (description "This library exposes internal types and functions that can