summary refs log tree commit diff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-05 14:22:28 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:14 +0200
commit9d1944a4939ae006b6f53c4203c49bc727c55dfd (patch)
treedca88af2c2be5a35d3d1cbd5987006114aaa9c3f /gnu/packages/haskell-check.scm
parent3c00bc13a5b78f0cfb240d60b4e283b1873b7ed9 (diff)
downloadguix-9d1944a4939ae006b6f53c4203c49bc727c55dfd.tar.gz
gnu: ghc-tasty: Update to 1.1.0.3.
* gnu/packages/haskell.scm (ghc-integer-logarithms-bootstrap,
ghc-scientific-bootstrap, ghc-attoparsec-bootstrap,
ghc-wcwidth-bootstrap): New variables to break a dependency cycle from
ghc-tasty.
* gnu/packages/haskell-check.scm (ghc-tasty): Update to 1.1.0.3.
[inputs]: Add ghc-wcwidth-bootstrap; remove ghc-regex-tdfa-rc.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index ef19645346..913835a807 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -181,7 +181,7 @@ timer functions of different operating systems via a unified API.")
 (define-public ghc-tasty
   (package
     (name "ghc-tasty")
-    (version "0.11.0.4")
+    (version "1.1.0.3")
     (source
      (origin
        (method url-fetch)
@@ -191,18 +191,18 @@ timer functions of different operating systems via a unified API.")
              ".tar.gz"))
        (sha256
         (base32
-         "05pxjzgbgjdn7477xry0ssjrnmnsydqiq6nm6ck8n2da1baliqp0"))))
+         "14riid753hjqr6lca1kgxpnvq0wykf0k3qc5jpag42hh8bszav22"))))
     (build-system haskell-build-system)
     (inputs
      `(("ghc-stm" ,ghc-stm)
        ("ghc-tagged" ,ghc-tagged)
        ("ghc-regex-tdfa" ,ghc-regex-tdfa)
-       ("ghc-regex-tdfa-rc" ,ghc-regex-tdfa-rc)
        ("ghc-optparse-applicative" ,ghc-optparse-applicative)
        ("ghc-unbounded-delays" ,ghc-unbounded-delays)
        ("ghc-async" ,ghc-async)
        ("ghc-ansi-terminal" ,ghc-ansi-terminal)
-       ("ghc-clock-bootstrap" ,ghc-clock-bootstrap)))
+       ("ghc-clock-bootstrap" ,ghc-clock-bootstrap)
+       ("ghc-wcwidth" ,ghc-wcwidth-bootstrap)))
     (home-page "http://documentup.com/feuerbach/tasty")
     (synopsis "Modern and extensible testing framework")
     (description "Tasty is a modern testing framework for Haskell.  It lets