summary refs log tree commit diff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 22:37:21 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:13 +0200
commitbc8bda501cb8d9156afe001a440589b893d7b110 (patch)
treed3b3ae045d120371073f2210d9e899aa6144e20f /gnu/packages/haskell-check.scm
parentd9404fc122530b21e00ec3d150742d9c20dee66a (diff)
downloadguix-bc8bda501cb8d9156afe001a440589b893d7b110.tar.gz
gnu: ghc-test-framework: Update to 0.8.2.0.
* gnu/packages/haskell.scm (ghc-semigroups-bootstrap, ghc-hashable-bootstrap,
ghc-nats-bootstrap, ghc-unordered-containers-bootstrap): New variables for
breaking a dependency cycle with ghc-test-framework.
* gnu/packages/haskell-check.scm (ghc-test-framework): Update to 0.8.2.0.
[arguments]: Add a phase to patch the Cabal file to allow a newer QuickCheck.
[inputs]: Add ghc-semigroups-bootstrap.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 57e7f0edc1..a9ff6af041 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -452,7 +452,7 @@ expressed in Haskell, using combinators defined in the QuickCheck library.")
 (define-public ghc-test-framework
   (package
     (name "ghc-test-framework")
-    (version "0.8.1.1")
+    (version "0.8.2.0")
     (source
      (origin
        (method url-fetch)
@@ -460,10 +460,17 @@ expressed in Haskell, using combinators defined in the QuickCheck library.")
                            "test-framework-" version ".tar.gz"))
        (sha256
         (base32
-         "0wxjgdvb1c4ykazw774zlx86550848wbsvgjgcrdzcgbb9m650vq"))))
+         "1hhacrzam6b8f10hyldmjw8pb7frdxh04rfg3farxcxwbnhwgbpm"))))
     (build-system haskell-build-system)
     (arguments
-     `(#:configure-flags (list "--allow-newer=time")))
+     `(#:tests? #f  ; FIXME: Tests do not build.
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'update-constraints
+           (lambda _
+             (substitute* "test-framework.cabal"
+               (("QuickCheck     >= 2\\.3 && < 2\\.10")
+                "QuickCheck     >= 2.3 && < 2.12")))))))
     (native-inputs
      `(("ghc-hunit" ,ghc-hunit)
        ("ghc-quickcheck" ,ghc-quickcheck)))
@@ -475,7 +482,8 @@ expressed in Haskell, using combinators defined in the QuickCheck library.")
        ("ghc-random" ,ghc-random)
        ("ghc-regex-posix" ,ghc-regex-posix)
        ("ghc-xml" ,ghc-xml)
-       ("ghc-libxml" ,ghc-libxml)))
+       ("ghc-libxml" ,ghc-libxml)
+       ("ghc-semigroups" ,ghc-semigroups-bootstrap)))
     (home-page "https://batterseapower.github.io/test-framework/")
     (synopsis "Framework for running and organising tests")
     (description