summary refs log tree commit diff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:19 +0200
commit35bc1a5991c0ed405b581f35377f98a7befb4f1e (patch)
tree521aeb395ef25afc265383a916166d5362524761 /gnu/packages/haskell-web.scm
parenta78c0059aa68180ecac6cc99487081540aaac192 (diff)
downloadguix-35bc1a5991c0ed405b581f35377f98a7befb4f1e.tar.gz
gnu: Add ghc-modern-uri.
* gnu/packages/haskell-web.scm (ghc-modern-uri): New variable.

Change-Id: I62d4c2722303cbeb9a7ef1acd3f12f355cf67509
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index cea4d09544..540b167b7a 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -923,6 +923,36 @@ library to allow use of the API library without testing dependencies.")
      "This library provides basic MIME type handling types and functions.")
     (license license:expat)))
 
+(define-public ghc-modern-uri
+  (package
+    (name "ghc-modern-uri")
+    (version "0.3.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "modern-uri" version))
+       (sha256
+        (base32 "1sag8l91qd7xs56rlx8r6dz9zxxmqsnfw0v47az7l8nirv7zjih2"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "modern-uri")))
+    (inputs (list ghc-quickcheck
+                  ghc-hashable
+                  ghc-megaparsec
+                  ghc-profunctors
+                  ghc-reflection
+                  ghc-tagged))
+    (native-inputs (list ghc-hspec
+                         ghc-hspec-megaparsec
+                         ghc-hspec-discover))
+    (arguments
+     `(#:cabal-revision ("1"
+                         "0c0mr8aqs963nmy7i8yfih24snaijgwkxim2q2khw12capshac0q")))
+    (home-page "https://github.com/mrkkrp/modern-uri")
+    (synopsis "Library for working with URIs")
+    (description "This is a library for working with URIs in Haskell as
+per RFC 3986.")
+    (license license:bsd-3)))
+
 (define-public ghc-html
   (package
     (name "ghc-html")