summary refs log tree commit diff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:19 +0200
commitb318f7c7d024928d1997bd423bbdd10566d196f2 (patch)
treedebf4cf95775d2fd19ea75eb002229a550b74ba6 /gnu/packages/haskell-web.scm
parent2324db2aba2d9601ba5d4a8bfb4e28b4e3e94a57 (diff)
downloadguix-b318f7c7d024928d1997bd423bbdd10566d196f2.tar.gz
gnu: Add ghc-crypton-connection.
* gnu/packages/haskell-web.scm (ghc-crypton-connection): New variable.

Change-Id: I37bc263de2aa9f3ce7b06b9a752424a0550bf6d3
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 0aaa609e42..9bfec863b0 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -89,6 +89,36 @@ for screen-scraping.")
     (description "HTTP cookie parsing and rendering library for Haskell.")
     (license license:expat)))
 
+(define-public ghc-crypton-connection
+  (package
+    (name "ghc-crypton-connection")
+    (version "0.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "crypton-connection" version))
+       (sha256
+        (base32 "07lrkv6lwphsyp4797yp8ywnndzd270bk58r8gwyby0hr4xy52r0"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "crypton-connection")))
+    (inputs (list ghc-basement
+                  ghc-data-default-class
+                  ghc-network
+                  ghc-tls-1.9
+                  ghc-socks
+                  ghc-crypton-x509
+                  ghc-crypton-x509-store
+                  ghc-crypton-x509-system
+                  ghc-crypton-x509-validation))
+    (home-page "https://github.com/kazu-yamamoto/crypton-connection")
+    (synopsis "Simple and easy network connections API")
+    (description
+     "This package provides a simple network library for all your connection
+needs.  Features: Really simple to use, SSL/TLS, SOCKS.  This library provides
+a very simple API to create sockets to a destination with the choice of
+SSL/TLS, and SOCKS.")
+    (license license:bsd-3)))
+
 (define-public ghc-curl
   (package
     (name "ghc-curl")