summary refs log tree commit diff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:19 +0200
commitfb64e563eb8ee7fcfe67451cf73d1ec1917bf9d6 (patch)
treea134ebe10ca672b7521b2296e298f5fa08b07df7 /gnu/packages/haskell-web.scm
parentb318f7c7d024928d1997bd423bbdd10566d196f2 (diff)
downloadguix-fb64e563eb8ee7fcfe67451cf73d1ec1917bf9d6.tar.gz
gnu: Add ghc-mattermost-api.
* gnu/packages/haskell-web.scm (ghc-mattermost-api): New variable.

Change-Id: Idc2a8fb0d8589b38d7e50aa7565fff71dcc6ab28
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 9bfec863b0..fc101fba05 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -844,6 +844,46 @@ attacks.")
 Haskell.")
     (license license:bsd-3)))
 
+(define-public ghc-mattermost-api
+  (package
+    (name "ghc-mattermost-api")
+    (version "90000.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "mattermost-api" version))
+       (sha256
+        (base32 "1ka3r4bnfwlbjnkws8vkg8i9gj8wzsyss137p7hxrx4sr75s6iyv"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "mattermost-api")))
+    (inputs (list ghc-websockets
+                  ghc-aeson
+                  ghc-crypton-connection
+                  ghc-memory
+                  ghc-resource-pool
+                  ghc-http
+                  ghc-http-media
+                  ghc-network-uri
+                  ghc-modern-uri
+                  ghc-unordered-containers
+                  ghc-hashable
+                  ghc-gitrev
+                  ghc-microlens
+                  ghc-microlens-th
+                  ghc-pretty-show
+                  ghc-split
+                  ghc-connection))
+    (native-inputs (list ghc-tasty ghc-tasty-hunit ghc-hunit))
+    (arguments
+     (list #:tests? #f)) ;tests require networking and Mattermost Docker image
+    (home-page "https://hackage.haskell.org/package/mattermost-api")
+    (synopsis "Client API for Mattermost chat system")
+    (description
+     "This package implements the client API for the Mattermost chat system.
+Mattermost is a flexible messaging platform.  This library provides network
+API interaction with the Mattermost server.")
+    (license license:bsd-3)))
+
 (define-public ghc-mime-types
   (package
     (name "ghc-mime-types")