summary refs log tree commit diff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-24 23:57:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-13 16:44:56 +0200
commit534d6caa0b41fa762b7db81962512a809e1918c7 (patch)
tree3918d9937449fe9c972af8644f291dc78aa0b2ad /gnu/packages/haskell-web.scm
parentaa1a75cc0ef2bf73f1a11d6123b48641e770016d (diff)
downloadguix-534d6caa0b41fa762b7db81962512a809e1918c7.tar.gz
gnu: Add "static" output to Haskell packages with custom outputs.
All these packages have non-standard outputs.  As a result the build system
cannot automatically add the "static" output, so we do this manually.

* gnu/packages/haskell-check.scm (ghc-quickcheck, ghc-hunit)[outputs]: Add
"static" output.
* gnu/packages/haskell-web.scm (ghc-http)[outputs]: Same.
* gnu/packages/haskell-xyz.scm (ghc-case-insensitive, ghc-fgl, ghc-hashable,
ghc-network, ghc-network-uri, ghc-parallel, ghc-paths, ghc-primitive,
ghc-random, ghc-split, ghc-syb, ghc-tf-random, ghc-unordered-containers,
ghc-vector, ghc-zlib)[outputs]: Same.
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index c53dc064b1..82da50f456 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -171,7 +171,7 @@ both client and server code).")
   (package
     (name "ghc-http")
     (version "4000.3.14")
-    (outputs '("out" "doc"))
+    (outputs '("out" "static" "doc"))
     (source
      (origin
        (method url-fetch)