summary refs log tree commit diff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 01:28:37 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:32 -0500
commit803e6780968967d9624ecbda794d7a7410e6f69c (patch)
tree184876f897d7c35434cfb42976023c23f6979f8a /gnu/packages/haskell-web.scm
parent5e2d41f467a605befd5e689e578a1ef2a81f4f7a (diff)
downloadguix-803e6780968967d9624ecbda794d7a7410e6f69c.tar.gz
gnu: ghc-bsb-http-chunked: Update to 0.0.0.4.
* gnu/packages/haskell-web.scm (ghc-bsb-http-chunked): Update to 0.0.0.4.
[inputs]: Remove 'ghc-bytestring-builder'.
[native-inputs]: Add 'ghc-attoparsec', 'ghc-blaze-builder',
'ghc-hedgehog', 'ghc-tasty', 'ghc-tasty-hedgehog', 'ghc-tasty-hunit',
and 'ghc-doctest'.
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index c5d216159b..eea7378e27 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -520,7 +520,7 @@ Haskell's Web Application Interface (WAI).")
 (define-public ghc-bsb-http-chunked
   (package
     (name "ghc-bsb-http-chunked")
-    (version "0.0.0.2")
+    (version "0.0.0.4")
     (source
      (origin
        (method url-fetch)
@@ -530,10 +530,16 @@ Haskell's Web Application Interface (WAI).")
              version ".tar.gz"))
        (sha256
         (base32
-         "1x6m6xkrcw6jiaig1bb2wb5pqyw31x8xr9k9pxgq2g3ng44pbjr8"))))
+         "0z0f18yc6zlwh29c6175ivfcin325lvi4irpvv0n3cmq7vi0k0ql"))))
     (build-system haskell-build-system)
-    (inputs
-     `(("ghc-bytestring-builder" ,ghc-bytestring-builder)))
+    (native-inputs
+     `(("ghc-attoparsec" ,ghc-attoparsec)
+       ("ghc-blaze-builder" ,ghc-blaze-builder)
+       ("ghc-hedgehog" ,ghc-hedgehog)
+       ("ghc-tasty" ,ghc-tasty)
+       ("ghc-tasty-hedgehog" ,ghc-tasty-hedgehog)
+       ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+       ("ghc-doctest" ,ghc-doctest)))
     (home-page "http://github.com/sjakobi/bsb-http-chunked")
     (synopsis "Chunked HTTP transfer encoding for bytestring builders")
     (description "This Haskell library contains functions for encoding