summary refs log tree commit diff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-10-10 17:32:24 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-10 17:32:24 +0200
commit4d14902b9402a83db444d8d6818d0a4f438ce8c4 (patch)
tree85f05a0540ebcd4a1f192096c36271a287eb9fe8 /gnu/packages/haskell-xyz.scm
parent647cfcf68184e8558fcea751ef6d95b6e5d86ae1 (diff)
parent6c50e1dc0625f89884cff40b22627091efa37708 (diff)
downloadguix-4d14902b9402a83db444d8d6818d0a4f438ce8c4.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 4313b6059e..2977398880 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -62,6 +62,7 @@
   #:use-module (guix build-system haskell)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix utils)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages))
 
@@ -6070,6 +6071,24 @@ Megaparsec is a feature-rich package that strikes a nice balance between
 speed, flexibility, and quality of parse errors.")
     (license license:bsd-2)))
 
+;;; Idris 1.3.2 requires 'megaparse>=7.0.4' but we'd like to keep the public
+;;; package at the current Stackage LTS version:
+(define-public ghc-megaparsec-7
+  (hidden-package
+   (package
+     (inherit ghc-megaparsec)
+     (version "7.0.5")
+     (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://hackage.haskell.org/package/megaparsec/"
+                            "megaparsec-" version ".tar.gz"))
+        (sha256
+         (base32
+          "0bqx1icbmk8s7wmbcdzsgnlh607c7kzg8l80cp02dxr5valjxp7j"))))
+     (arguments (strip-keyword-arguments (list #:cabal-revision)
+                                         (package-arguments ghc-megaparsec))))))
+
 (define-public ghc-memory
   (package
     (name "ghc-memory")
@@ -6740,6 +6759,24 @@ between 2 and 3 times faster than the Mersenne Twister.")
      "This package provides a low-level networking interface.")
     (license license:bsd-3)))
 
+;;; Until we update our default GHC to >=8.6 we cannot update our ghc-network
+;;; package, since the 'cabal-install' package that supports the current
+;;; 'Cabal' module requires 'network==2.6.*'.  Here we provide an updated
+;;; version to be used for our idris package.
+(define-public ghc-network-2.8
+  (hidden-package
+   (package
+     (inherit ghc-network)
+     (version "2.8.0.1")
+     (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://hackage.haskell.org/package/network/"
+                            "network-" version ".tar.gz"))
+        (sha256
+         (base32
+          "0im8k51rw3ahmr23ny10pshwbz09jfg0fdpam0hzf2hgxnzmvxb1")))))))
+
 (define-public ghc-network-info
   (package
     (name "ghc-network-info")
@@ -7801,7 +7838,7 @@ examination.")
        ("ghc-listlike" ,ghc-listlike)))
     (home-page "https://github.com/seereason/process-extras")
     (synopsis "Extra tools for managing processes")
-    (description "This packages extends
+    (description "This package extends
 @url{http://hackage.haskell.org/package/process}.  It allows you to read
 process input and output as ByteStrings or Text, or write your own
 ProcessOutput instance.  It also provides lazy process input and output,