summary refs log tree commit diff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-02-08 15:07:22 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-02-08 15:39:55 +0100
commite90a06fcc55b6bef68e8fed88eebed403058f55c (patch)
tree1ff8f1a3ff523b82ec7a245455ecdf094b77f125 /gnu/packages/haskell-xyz.scm
parentd56c8120277ed9ad0b6cf6eb1183f918590c8259 (diff)
downloadguix-e90a06fcc55b6bef68e8fed88eebed403058f55c.tar.gz
gnu: Add ghc-text-conversions.
* gnu/packages/haskell-xyz.scm (ghc-text-conversions): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 1a70ef4587..ea9efe70fd 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8222,6 +8222,31 @@ require aeson
 @end itemize")
     (license license:bsd-3)))
 
+(define-public ghc-text-conversions
+  (package
+    (name "ghc-text-conversions")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/text-conversions/"
+             "text-conversions-" version ".tar.gz"))
+       (sha256
+        (base32 "089c56vdj9xysqfr1hnvbnrghlg83q6w10xk02gflpsidcpvwmhp"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-base16-bytestring" ,ghc-base16-bytestring)
+       ("ghc-base64-bytestring" ,ghc-base64-bytestring)
+       ("ghc-errors" ,ghc-errors)))
+    (native-inputs
+     `(("ghc-hspec" ,ghc-hspec)
+       ("ghc-hspec-discover" ,ghc-hspec-discover)))
+    (home-page "https://github.com/cjdev/text-conversions#readme")
+    (synopsis "Safe conversions between textual types")
+    (description "Safe conversions between textual types")
+    (license license:isc)))
+
 (define-public ghc-doclayout
   (package
     (name "ghc-doclayout")