summary refs log tree commit diff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorCarlo Holl <carloholl@gmail.com>2020-10-31 19:02:31 -0700
committerChristopher Baines <mail@cbaines.net>2020-11-01 13:34:46 +0000
commit3a09211c1b73b30d7bc9ceb0ddd1f55e9308f908 (patch)
tree8f954437d7756d6945c878796f0c4e6784a54fd8 /gnu/packages/haskell-xyz.scm
parent094a9d7ac490e5b745deb0a8be050d6572f71a60 (diff)
downloadguix-3a09211c1b73b30d7bc9ceb0ddd1f55e9308f908.tar.gz
gnu: Add ghc-uglymemo.
* gnu/packages/haskell-xyz.scm (ghc-uglymemo): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 71cf8609cb..827b1f80c7 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13863,6 +13863,28 @@ processes.  It wraps around the @code{process} library, and intends to improve
 upon it.")
     (license license:expat)))
 
+(define-public ghc-uglymemo
+  (package
+    (name "ghc-uglymemo")
+    (version "0.1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/uglymemo/uglymemo-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0ixqg5d0ly1r18jbgaa89i6kjzgi6c5hanw1b1y8c5fbq14yz2gy"))))
+    (build-system haskell-build-system)
+    (home-page "https://hackage.haskell.org/package/uglymemo")
+    (synopsis "Simple memoization function for Haskell")
+    (description
+     "This package provides a simple (but internally ugly) memoization
+function.")
+    (license license:public-domain)))
+
 (define-public ghc-unagi-chan
   (package
     (name "ghc-unagi-chan")