summary refs log tree commit diff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-08 23:07:49 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:49 -0500
commit801cf5b13a7c4cf4a4c31722c13f52406e3de02c (patch)
treeb56478d616c1508fec88b9891277eddd3fb99e9a /gnu/packages/haskell-xyz.scm
parent74a7dd7ff469da85eba8b9301bc96e1f1b2fb971 (diff)
downloadguix-801cf5b13a7c4cf4a4c31722c13f52406e3de02c.tar.gz
gnu: ghc-equivalence: Update to 0.3.5.
* gnu/packages/haskell-xyz.scm (ghc-equivalence): Update to 0.3.5.
[inputs]: Remove 'ghc-test-framework' and
'ghc-test-framework-quickcheck2'; add 'ghc-fail'.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 45ff1e8638..9139807562 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3203,21 +3203,20 @@ asynchronous exceptions.")
 (define-public ghc-equivalence
   (package
     (name "ghc-equivalence")
-    (version "0.3.2")
+    (version "0.3.5")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://hackage.haskell.org/package/equivalence"
                            "/equivalence-" version ".tar.gz"))
        (sha256
-        (base32 "0a85bdyyvjqs5z4kfhhf758210k9gi9dv42ik66a3jl0z7aix8kx"))))
+        (base32 "167njzd1cf32aa7br90rjafrxy6hw3fxkk8awifqbxjrcwm5maqp"))))
     (build-system haskell-build-system)
     (inputs
      `(("ghc-stmonadtrans" ,ghc-stmonadtrans)
        ("ghc-transformers-compat" ,ghc-transformers-compat)
-       ("ghc-quickcheck" ,ghc-quickcheck)
-       ("ghc-test-framework" ,ghc-test-framework)
-       ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
+       ("ghc-fail" ,ghc-fail)
+       ("ghc-quickcheck" ,ghc-quickcheck)))
     (home-page "https://github.com/pa-ba/equivalence")
     (synopsis "Maintaining an equivalence relation implemented as union-find")
     (description