summary refs log tree commit diff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-25 14:28:43 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-11-02 09:32:55 +0100
commit0423272c1c6b54ef513958926533368544581205 (patch)
tree08aa94c1eba3801f520ba55168f1ab91635e5ae7 /gnu/packages/haskell-xyz.scm
parentf66c69a32d2985393bd56e4050d025d024ff7a68 (diff)
downloadguix-0423272c1c6b54ef513958926533368544581205.tar.gz
gnu: ghc-mysql-simple: Update to 0.4.7.
* gnu/packages/haskell-xyz.scm (ghc-mysql-simple): Update to 0.4.7.
[inputs]: Add ghc-vector.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index c6644a7669..ddad796c9d 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16220,7 +16220,7 @@ Haskell datatypes in text form using the @code{ghc-blaze-builder} library.")
 (define-public ghc-mysql-simple
   (package
     (name "ghc-mysql-simple")
-    (version "0.4.6")
+    (version "0.4.7")
     (source
      (origin
        (method url-fetch)
@@ -16229,7 +16229,7 @@ Haskell datatypes in text form using the @code{ghc-blaze-builder} library.")
              version
              ".tar.gz"))
        (sha256
-        (base32 "1am8ck092s9cv4x1ambalil4mlazkp8w5qhjbl4nq0j2hpy73rby"))))
+        (base32 "1mhmszpq64h8kxr20iaj1laq46wr2gaqc8xxq1k821i7jfxfld6j"))))
     (build-system haskell-build-system)
     (arguments `(#:tests? #f)) ; TODO: Fails to connect to server.
     (inputs
@@ -16240,6 +16240,7 @@ Haskell datatypes in text form using the @code{ghc-blaze-builder} library.")
        ("ghc-pcre-light" ,ghc-pcre-light)
        ("ghc-old-locale" ,ghc-old-locale)
        ("ghc-blaze-textual" ,ghc-blaze-textual)
+       ("ghc-vector" ,ghc-vector)
        ("openssl" ,openssl)
        ("zlib" ,zlib)))
     (native-inputs `(("ghc-hspec" ,ghc-hspec)))