summary refs log tree commit diff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-25 14:28:36 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-11-02 09:32:51 +0100
commit607a5c4754d757051db76e656a066ce4573d40ea (patch)
treebeaa0d44954f400e1a55faf84cc4e4e90ed87d92 /gnu/packages/haskell-xyz.scm
parentf4f5fca49ca36553e2eb0c06df26f26db11df418 (diff)
downloadguix-607a5c4754d757051db76e656a066ce4573d40ea.tar.gz
gnu: ghc-ipynb: Update to 0.1.0.2.
* gnu/packages/haskell-xyz.scm (ghc-ipynb): Update to 0.1.0.2.
[native-inputs]: Remove ghc-aeson-diff and ghc-vector.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f166969de1..6d5d98cee3 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6798,7 +6798,7 @@ removed.  Both IPv4 and IPv6 are supported.")
 (define-public ghc-ipynb
   (package
     (name "ghc-ipynb")
-    (version "0.1.0.1")
+    (version "0.1.0.2")
     (source
      (origin
        (method url-fetch)
@@ -6806,7 +6806,7 @@ removed.  Both IPv4 and IPv6 are supported.")
                            "ipynb/ipynb-" version ".tar.gz"))
        (sha256
         (base32
-         "0lwpz0ip7r1rxkirqb6p48ql19fzamqkrnf3khx7bfl5wsxi6yrb"))))
+         "0qky4l5aaiq7ypwbxh0mr7s572290fi596f18dg68qpyzc49a9kx"))))
     (build-system haskell-build-system)
     (inputs
      `(("ghc-unordered-containers" ,ghc-unordered-containers)
@@ -6816,10 +6816,8 @@ removed.  Both IPv4 and IPv6 are supported.")
     (native-inputs
      `(("ghc-tasty" ,ghc-tasty)
        ("ghc-tasty-hunit" ,ghc-tasty-hunit)
-       ("ghc-aeson-diff" ,ghc-aeson-diff)
        ("ghc-microlens-aeson" ,ghc-microlens-aeson)
-       ("ghc-microlens" ,ghc-microlens)
-       ("ghc-vector" ,ghc-vector)))
+       ("ghc-microlens" ,ghc-microlens)))
     (home-page "https://hackage.haskell.org/package/ipynb")
     (synopsis "Data structure for working with Jupyter notebooks")
     (description "This library defines a data structure for representing