summary refs log tree commit diff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 13:23:47 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:38 -0500
commit06344a3a39b773972a8e8e8d2acf8d1722618e9c (patch)
treec1b467b7704c60922ec3eb434e1ec78683618ad8 /gnu/packages/haskell-xyz.scm
parent1f656b17d9c5d148f07e01d28044d84ba3a91679 (diff)
downloadguix-06344a3a39b773972a8e8e8d2acf8d1722618e9c.tar.gz
gnu: ghc-hpack: Update to 0.31.2.
* gnu/packages/haskell-xyz.scm (ghc-hpack): Update to 0.31.2.
[source]: Use a patch to fix tests.
[inputs]: Add 'ghc-infer-license'.
* gnu/packages/patches/ghc-hpack-fix-tests.patch: New file.
* gnu/local.mk: Add it.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e0aa5ee23a..14d9d6924b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4953,15 +4953,16 @@ representations of current time.")
 (define-public ghc-hpack
   (package
     (name "ghc-hpack")
-    (version "0.28.2")
+    (version "0.31.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://hackage.haskell.org/package/hpack/"
                            "hpack-" version ".tar.gz"))
+       (patches (search-patches "ghc-hpack-fix-tests.patch"))
        (sha256
         (base32
-         "18w0h76jdp3mk9vin8da9iz3cwhcxmw787xy8wlh8bxcpcr16q5r"))))
+         "1l2d6185lawwhsj70swxkvcacm0hvcn9qsrlx4ph4gs6k578603g"))))
     (build-system haskell-build-system)
     (inputs
      `(("ghc-aeson" ,ghc-aeson)
@@ -4971,6 +4972,7 @@ representations of current time.")
        ("ghc-http-client" ,ghc-http-client)
        ("ghc-http-client-tls" ,ghc-http-client-tls)
        ("ghc-http-types" ,ghc-http-types)
+       ("ghc-infer-license" ,ghc-infer-license)
        ("ghc-scientific" ,ghc-scientific)
        ("ghc-unordered-containers" ,ghc-unordered-containers)
        ("ghc-vector" ,ghc-vector)