summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-21 12:49:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-21 12:49:34 +0300
commit0fc0ce23421243fae99f53c013a4c80b51f128ef (patch)
treea4715d6730d5bd752444a220ca872f12376872e7 /gnu/packages/haskell.scm
parent7032e0bc8acfa37581feedeaf91bff04fe47ba6a (diff)
downloadguix-0fc0ce23421243fae99f53c013a4c80b51f128ef.tar.gz
gnu: ghc-7: Unpack tarballs from the store.
* gnu/packages/haskell.scm (ghc-7)[arguments]: Adjust custom 'unpack-bin
and 'unpack-testsuite-and-fix-bins phases to unpack tarballs directly
from the store.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 59adcc8185..29a79289d8 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -484,15 +484,11 @@ libraries are included in this package.")
                (lambda* (#:key inputs outputs #:allow-other-keys)
                 (mkdir-p ghc-bootstrap-prefix)
                 (with-directory-excursion ghc-bootstrap-path
-                  (copy-file (assoc-ref inputs "ghc-binary")
-                             "ghc-bin.tar.xz")
-                  (invoke "tar" "xvf" "ghc-bin.tar.xz"))))
+                  (invoke "tar" "xvf" (assoc-ref inputs "ghc-binary")))))
              (add-after 'unpack-bin 'unpack-testsuite-and-fix-bins
                (lambda* (#:key inputs outputs #:allow-other-keys)
                  (with-directory-excursion ".."
-                   (copy-file (assoc-ref inputs "ghc-testsuite")
-                              "ghc-testsuite.tar.xz")
-                   (invoke "tar" "xvf" "ghc-testsuite.tar.xz"))
+                   (invoke "tar" "xvf" (assoc-ref inputs "ghc-testsuite")))
                  (substitute*
                    (list "testsuite/timeout/Makefile"
                          "testsuite/timeout/timeout.py"