summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRobert Vollmert <rob@vllmrt.net>2019-08-01 18:11:35 +0200
committerTimothy Sample <samplet@ngyro.com>2019-08-07 22:05:33 -0400
commit3755088b54ba83bf539d5afd8ec4f6dbc44be560 (patch)
tree309b44e5a38d50dd4d5dcdd00cec3c01e63321e1 /gnu/packages/haskell.scm
parent63edeca7730e877441af1946ff9b6e255d17afc7 (diff)
downloadguix-3755088b54ba83bf539d5afd8ec4f6dbc44be560.tar.gz
gnu: Remove ghc-packedstring.
The package has no reverse dependencies and is deprecated upstream.

* gnu/packages/haskell.scm (ghc-packedstring): Remove variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 403827f0d9..d7cbd37394 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5896,35 +5896,6 @@ within an enclosed computation, while remaining responsive to (external)
 asynchronous exceptions.")
     (license license:expat)))
 
-(define-public ghc-packedstring
-  (package
-    (name "ghc-packedstring")
-    (version "0.1.0.1")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://hackage.haskell.org/package/"
-                                  "packedstring/packedstring-"
-                                  version ".tar.gz"))
-              (sha256
-               (base32
-                "1x78pzzdlnpcmh9p37rlf8m5cxf3yqm2alf3whl4zpr9w25r0qj8"))))
-    (build-system haskell-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'enable-extension
-          (lambda _
-            ;; This package won't compile without the StandaloneDeriving
-            ;; extension.
-            (substitute* "packedstring.cabal"
-              (("CPP") "CPP, StandaloneDeriving"))
-            #t)))))
-    (home-page "https://hackage.haskell.org/package/packedstring")
-    (synopsis "Library for packed strings")
-    (description
-     "This deprecated library provides an implementation of packed strings.")
-    (license license:bsd-3)))
-
 (define-public ghc-th-abstraction
   (package
     (name "ghc-th-abstraction")