summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2017-01-03 21:23:36 +0100
committerDavid Craven <david@craven.ch>2017-01-04 11:51:36 +0100
commitae482ce12d19f7d8d58677a8c56c9581fa1c50fc (patch)
tree8c1dd3078f967fee154f7b12f1f58a9e7350d03e /gnu/packages/haskell.scm
parentc7a7129c5a3c02bd000be73ea7c7c26189c370b7 (diff)
downloadguix-ae482ce12d19f7d8d58677a8c56c9581fa1c50fc.tar.gz
gnu: idris: Move to (gnu packages idris).
* gnu/packages/haskell.scm: Move 'idris' to...
* gnu/packages/idris.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add idris.scm.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm82
1 files changed, 0 insertions, 82 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index eda3a7b72d..de061a6300 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6669,88 +6669,6 @@ constant-time:
 @end enumerate\n")
     (license license:bsd-3)))
 
-(define-public idris
-  (package
-    (name "idris")
-    (version "0.99")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://hackage.haskell.org/package/"
-                    "idris-" version "/idris-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1sd4vy5rx0mp32xj99qijhknkgw4d2rxvz6wiy3pym6kaqmc497i"))))
-    (build-system haskell-build-system)
-    (inputs
-     `(("gmp" ,gmp)
-       ("ncurses" ,ncurses)
-       ("ghc-aeson" ,ghc-aeson)
-       ("ghc-async" ,ghc-async)
-       ("ghc-annotated-wl-pprint" ,ghc-annotated-wl-pprint)
-       ("ghc-ansi-terminal" ,ghc-ansi-terminal)
-       ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
-       ("ghc-base64-bytestring" ,ghc-base64-bytestring)
-       ("ghc-blaze-html" ,ghc-blaze-html)
-       ("ghc-blaze-markup" ,ghc-blaze-markup)
-       ("ghc-cheapskate" ,ghc-cheapskate)
-       ("ghc-fingertree" ,ghc-fingertree)
-       ("ghc-fsnotify" ,ghc-fsnotify)
-       ("ghc-ieee754" ,ghc-ieee754)
-       ("ghc-mtl" ,ghc-mtl)
-       ("ghc-network" ,ghc-network)
-       ("ghc-optparse-applicative" ,ghc-optparse-applicative)
-       ("ghc-parsers" ,ghc-parsers)
-       ("ghc-regex-tdfa" ,ghc-regex-tdfa)
-       ("ghc-safe" ,ghc-safe)
-       ("ghc-split" ,ghc-split)
-       ("ghc-tasty" ,ghc-tasty)
-       ("ghc-tasty-golden" ,ghc-tasty-golden)
-       ("ghc-tasty-rerun" ,ghc-tasty-rerun)
-       ("ghc-terminal-size" ,ghc-terminal-size)
-       ("ghc-text" ,ghc-text)
-       ("ghc-trifecta" ,ghc-trifecta)
-       ("ghc-uniplate" ,ghc-uniplate)
-       ("ghc-unordered-containers" ,ghc-unordered-containers)
-       ("ghc-utf8-string" ,ghc-utf8-string)
-       ("ghc-vector-binary-instances" ,ghc-vector-binary-instances)
-       ("ghc-vector" ,ghc-vector)
-       ("ghc-zip-archive" ,ghc-zip-archive)
-       ("ghc-zlib" ,ghc-zlib)))
-    (arguments
-     `(#:tests? #f ; FIXME: Test suite doesn't run in a sandbox.
-       #:configure-flags
-       (list (string-append "--datasubdir="
-                            (assoc-ref %outputs "out") "/lib/idris"))
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'set-cc-command
-           (lambda _
-             (setenv "CC" "gcc")
-             #t))
-         (add-after 'install 'fix-libs-install-location
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (lib (string-append out "/lib/idris"))
-                    (modules (string-append lib "/libs")))
-               (for-each
-                (lambda (module)
-                  (symlink (string-append modules "/" module)
-                           (string-append lib "/" module)))
-                '("prelude" "base" "contrib" "effects" "pruviloj"))))))))
-    (native-search-paths
-     (list (search-path-specification
-            (variable "IDRIS_LIBRARY_PATH")
-            (files '("lib/idris")))))
-    (home-page "http://www.idris-lang.org")
-    (synopsis "General purpose language with full dependent types")
-    (description "Idris is a general purpose language with full dependent
-types.  It is compiled, with eager evaluation.  Dependent types allow types to
-be predicated on values, meaning that some aspects of a program's behaviour
-can be specified precisely in the type.  The language is closely related to
-Epigram and Agda.")
-    (license license:bsd-3)))
-
 (define-public ghc-base16-bytestring
   (package
     (name "ghc-base16-bytestring")