summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-08-22 15:16:58 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-08-22 15:35:32 +0200
commit76eb007990fb494f5969570fe52bad4aaa7f2dbf (patch)
tree2ba346f02df6afcedf10eb7ba964b296d30eb045 /gnu/packages/haskell.scm
parent29b60130d8a3d89b9562043a3ce07a1c0c644cf0 (diff)
downloadguix-76eb007990fb494f5969570fe52bad4aaa7f2dbf.tar.gz
gnu: shellcheck: Update to 0.7.0.
* gnu/packages/haskell.scm (shellcheck): Update to 0.7.0.
[inputs]: Add ghc-diff.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8787f10789..b544190895 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8361,7 +8361,7 @@ generated SQL and optimize it for your backend.")
 (define-public shellcheck
   (package
     (name "shellcheck")
-    (version "0.5.0")
+    (version "0.7.0")
     (source
      (origin
        (method url-fetch)
@@ -8369,12 +8369,12 @@ generated SQL and optimize it for your backend.")
              "https://hackage.haskell.org/package/ShellCheck/ShellCheck-"
              version ".tar.gz"))
        (sha256
-        (base32
-         "0z1hscbr11hwkq8k1v0vaa947hb9m6k4cm831jk1gpj8dxrk151b"))
+        (base32 "1vx895cp5k5h0680xfwj74lk97m9y627n965x6srds0gfnbkzy9s"))
        (file-name (string-append name "-" version ".tar.gz"))))
     (build-system haskell-build-system)
     (inputs
      `(("ghc-aeson" ,ghc-aeson)
+       ("ghc-diff" ,ghc-diff)
        ("ghc-quickcheck" ,ghc-quickcheck)
        ("ghc-regex-tdfa" ,ghc-regex-tdfa)))
     (home-page "https://github.com/koalaman/shellcheck")