summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-06-15 01:23:48 +0000
committerLudovic Courtès <ludo@gnu.org>2017-06-16 10:26:39 +0200
commit789dc5680f8a52af57e5f90174c9032d3af3fb51 (patch)
tree11652aead8e10353f323b182e3aa8185f77bebd3 /gnu/packages/haskell.scm
parentd14e3435caa6e23ea1d03393dae1fc9f2cb5275d (diff)
downloadguix-789dc5680f8a52af57e5f90174c9032d3af3fb51.tar.gz
gnu: Add ghc-simple-sendfile
* gnu/packages/haskell.scm (ghc-simple-sendfile): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b52aa9f0f5..1d487386c1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8347,4 +8347,32 @@ Haskell's Web Application Interface (WAI).")
 Date in Haskell.")
     (license license:bsd-3)))
 
+(define-public ghc-simple-sendfile
+  (package
+    (name "ghc-simple-sendfile")
+    (version "0.2.25")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "simple-sendfile-" version "/"
+                           "simple-sendfile-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0k99j9xfcf83c55jmn202hdinhjaa4yn3dal4rvjk2w2rlhqirha"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-conduit" ,ghc-conduit)
+       ("ghc-conduit-extra" ,ghc-conduit-extra)
+       ("ghc-network" ,ghc-network)
+       ("ghc-resourcet" ,ghc-resourcet)))
+    (native-inputs
+     `(("ghc-hspec" ,ghc-hspec)
+       ("hspec-discover" ,hspec-discover)))
+    (home-page "https://github.com/kazu-yamamoto/simple-sendfile")
+    (synopsis "Cross platform library for the sendfile system call")
+    (description "This library tries to call minimum system calls which
+are the bottleneck of web servers.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here