summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:10 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:58 -0400
commitddd5955b1ed0b4a3d67d91d027ee88165bf865e3 (patch)
tree408922d0c08ea5790a7642821d3d598693ea7660 /gnu/packages/haskell.scm
parent2b41f4afc113bf7ea8d5151e5e389ae36d2c720b (diff)
downloadguix-ddd5955b1ed0b4a3d67d91d027ee88165bf865e3.tar.gz
gnu: Add ghc-system-filepath-bootstrap.
* gnu/packages/haskell.scm (ghc-system-filepath-bootstrap): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 92f3ccf413..00f5872b8d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7125,4 +7125,35 @@ a vocabulary for working with them.")
 instance of @code{MonadBase} or @code{MonadBaseControl}.")
     (license license:bsd-3)))
 
+;; Ghc-shelly depends on ghc-system-filepath and ghc-system-fileio, who in turn depend on
+;; ghc-chell and ghc-chell-quickcheck for the test phase. Ghc-chell depends on ghc-options
+;; which depends on ghc-chell and ghc-chell-quickcheck.
+;; Therefore we bootstrap it with tests disabled.
+(define ghc-system-filepath-bootstrap
+  (package
+    (name "ghc-system-filepath-bootstrap")
+    (version "0.4.13.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/system-filepath/system-filepath-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "1yy5zsmmimhg6iaw9fmpwrxvxrgi5s6bfyqfihdsnx4bjvn7sp9l"))))
+    (build-system haskell-build-system)
+    (arguments
+     `(#:tests? #f))
+    (inputs
+     `(("ghc-text" ,ghc-text)
+       ("ghc-quickcheck" ,ghc-quickcheck)))
+    (home-page "https://github.com/fpco/haskell-filesystem")
+    (synopsis "High-level, byte-based file and directory path manipulations")
+    (description
+     "Provides a FilePath datatype and utility functions for operating on it.
+Unlike the filepath package, this package does not simply reuse String,
+increasing type safety.")
+    (license license:expat)))
+
 ;;; haskell.scm ends here