summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-02-20 23:13:57 -0500
committerLudovic Courtès <ludo@gnu.org>2018-06-01 13:50:27 +0200
commit4e5d9bf20ecd8c888956c029fa5c47a74182b347 (patch)
tree06218e873916c559d5f10b63fa651c980345d3b9 /gnu/packages/haskell.scm
parent1ea3971992068944977cb031cc6b21018bdd001e (diff)
downloadguix-4e5d9bf20ecd8c888956c029fa5c47a74182b347.tar.gz
gnu: Add ghc-disk-free-space.
* gnu/packages/haskell.scm (ghc-disk-free-space): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 073f5b739f..42670d6e41 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9656,4 +9656,24 @@ serialization code.")
    (home-page "https://hackage.haskell.org/package/bytes")
    (license license:bsd-3)))
 
+(define-public ghc-disk-free-space
+  (package
+    (name "ghc-disk-free-space")
+    (version "0.1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "disk-free-space/disk-free-space-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "07rqj8k1vh3cykq9yidpjxhgh1f7vgmjs6y1nv5kq2217ff4yypi"))))
+    (build-system haskell-build-system)
+    (home-page "https://github.com/redneb/disk-free-space")
+    (synopsis "Retrieve information about disk space usage")
+    (description "A cross-platform library for retrieving information about
+disk space usage.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here