summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-26 17:08:57 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:50 +0100
commit536b84a8327f46e920c7aacabe4b3f5e8012af1a (patch)
tree1ef518d47f4a4a20e18befa8d57461ae2cf2cb69 /gnu/packages/haskell.scm
parent25101be9dcf633e9e9a2f12c7d05d2d62f3c3eff (diff)
downloadguix-536b84a8327f46e920c7aacabe4b3f5e8012af1a.tar.gz
gnu: Add ghc-th-reify-many.
* gnu/packages/haskell.scm (ghc-th-reify-many): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index cf5a1be87e..d5b0a01148 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5257,6 +5257,32 @@ datatypes.")
 @dfn{abstract syntax trees} (ASTs).")
     (license bsd-3)))
 
+(define-public ghc-th-reify-many
+  (package
+    (name "ghc-th-reify-many")
+    (version "0.1.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://hackage.haskell.org/package/"
+                                  "th-reify-many/th-reify-many-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "00hryljcs434wcv1vaamfdbjk857f46djxv7mlwplkl3zsmfhlfx"))))
+    (build-system haskell-build-system)
+    (propagated-inputs
+     `(("ghc-mtl" ,ghc-mtl)
+       ("ghc-safe" ,ghc-safe)
+       ("ghc-th-expand-syns" ,ghc-th-expand-syns)))
+    (home-page "http://github.com/mgsloan/th-reify-many")
+    (synopsis "Recurseively reify template haskell datatype info")
+    (description
+     "th-reify-many provides functions for recursively reifying top level
+declarations.  The main intended use case is for enumerating the names of
+datatypes reachable from an initial datatype, and passing these names to some
+function which generates instances.")
+    (license bsd-3)))
+
 (define-public idris
   (package
     (name "idris")