summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:27 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:14 -0700
commit897d4f2820dc7c067f44eb89e03ee7198c7add50 (patch)
tree2c7f870b64b020db69ffd744f18c917702845dc6 /gnu/packages/haskell.scm
parent30aede1b6f80de11611e2fc45c052d967a474be5 (diff)
downloadguix-897d4f2820dc7c067f44eb89e03ee7198c7add50.tar.gz
gnu: Add ghc-language-haskell-extract.
* gnu/packages/haskell.scm
(ghc-language-haskell-extract): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c5877859c2..d3ac021531 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9172,4 +9172,32 @@ between 2 and 3 times faster than the Mersenne Twister.")
     (description "This Haskell library algorithms for vector arrays.")
     (license license:bsd-3)))
 
+(define-public ghc-language-haskell-extract
+  (package
+    (name "ghc-language-haskell-extract")
+    (version "0.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "language-haskell-extract-" version "/"
+                           "language-haskell-extract-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1nxcs7g8a1sp91bzpy4cj6s31k5pvc3gvig04cbrggv5cvjidnhl"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-regex-posix" ,ghc-regex-posix)))
+    (home-page "https://github.com/finnsson/template-helper")
+    (synopsis "Haskell module to automatically extract functions from
+the local code")
+    (description "This package contains helper functions on top of
+Template Haskell.
+
+For example, @code{functionExtractor} extracts all functions after a
+regexp-pattern, which can be useful if you wish to extract all functions
+beginning with @code{test} (for a test framework) or all functions beginning
+with @code{wc} (for a web service).")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here