summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 11:34:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:40 +0100
commit7c86efe77639abdd7dc1481650d05f08fbf48800 (patch)
tree92bb1b878084df06f9db359702ac422cb29d0608 /gnu/packages/haskell.scm
parente41fad216d658681dbce671fcc6838faf0e4f2e2 (diff)
downloadguix-7c86efe77639abdd7dc1481650d05f08fbf48800.tar.gz
gnu: ghc-optparse-applicative: Update to 0.13.0.0.
* gnu/packages/haskell.scm (ghc-optparse-applicative): Update to 0.13.0.0.
[arguments]: Disable tests.
[native-inputs]: Add ghc-quickcheck.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 1d1c440014..af9ee3a29b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3928,7 +3928,7 @@ simple general-purpose data structure\".")
 (define-public ghc-optparse-applicative
   (package
     (name "ghc-optparse-applicative")
-    (version "0.11.0.2")
+    (version "0.13.0.0")
     (source
      (origin
        (method url-fetch)
@@ -3937,11 +3937,20 @@ simple general-purpose data structure\".")
              "/optparse-applicative-" version ".tar.gz"))
        (sha256
         (base32
-         "0ni52ii9555jngljvzxn1ngicr6i2w647ww3rzhdrmng04y95iii"))))
+         "1b0c5fdq8bd070g24vrjrwlq979r8dk8mys6aji9hy1l9pcv3inf"))))
     (build-system haskell-build-system)
+    ;; These tests fail because the package doesn't come with all needed test
+    ;; files:
+    ;; - prop_drops_back_contexts
+    ;; - prop_context_carry
+    ;; - prop_help_on_empty
+    ;; - prop_help_on_empty_sub
+    (arguments `(#:tests? #f))
     (inputs
      `(("ghc-transformers-compat" ,ghc-transformers-compat)
        ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)))
+    (native-inputs
+     `(("ghc-quickcheck" ,ghc-quickcheck)))
     (home-page "https://github.com/pcapriotti/optparse-applicative")
     (synopsis "Utilities and combinators for parsing command line options")
     (description "This package provides utilities and combinators for parsing