summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 23:36:42 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:13 +0200
commitd9404fc122530b21e00ec3d150742d9c20dee66a (patch)
treeeeca94e8c6c336ef66db37cd7ae767f753625c23 /gnu/packages/haskell.scm
parent5209fc22e1fe1c24f154b0eeecc2b5587aa64a1f (diff)
downloadguix-d9404fc122530b21e00ec3d150742d9c20dee66a.tar.gz
gnu: ghc-vector-algorithms: Update to 0.7.0.4.
* gnu/packages/haskell.scm (ghc-vector-algorithms): Update to 0.7.0.4.
[arguments]: Remove unneeded "--allow-newer=vector" configure flag; remove
test-patching phase.
[inputs]: Remove ghc-mwc-random.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm18
1 files changed, 3 insertions, 15 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index fce0c81c3e..6036a12ee1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8490,7 +8490,7 @@ between 2 and 3 times faster than the Mersenne Twister.")
 (define-public ghc-vector-algorithms
   (package
     (name "ghc-vector-algorithms")
-    (version "0.7.0.1")
+    (version "0.7.0.4")
     (source
      (origin
        (method url-fetch)
@@ -8499,22 +8499,10 @@ between 2 and 3 times faster than the Mersenne Twister.")
                            "vector-algorithms-" version ".tar.gz"))
        (sha256
         (base32
-         "0w4hf598lpxfg58rnimcqxrbnpqq2jmpjx82qa5md3q6r90hlipd"))))
+         "0mfa8ig9v69l41p2vb5jl4qmaln5y1rlzarr2mlgm8g1nvq8qqdg"))))
     (build-system haskell-build-system)
-    ;; The limits have been adjusted in a revision of the cabal file.
-    (arguments
-     '(#:configure-flags (list "--allow-newer=vector")
-       #:phases
-       (modify-phases %standard-phases
-         ;; The tests cannot be built due to type errors.
-         (add-after 'unpack 'do-not-build-quickcheck-tests
-           (lambda _
-             (substitute* "vector-algorithms.cabal"
-               (("\\!flag\\(properties\\)") "True"))
-             #t)))))
     (inputs
-     `(("ghc-vector" ,ghc-vector)
-       ("ghc-mwc-random" ,ghc-mwc-random)))
+     `(("ghc-vector" ,ghc-vector)))
     (native-inputs
      `(("ghc-quickcheck" ,ghc-quickcheck)))
     (home-page "https://github.com/bos/math-functions")