summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-15 23:18:30 -0400
committerMark H Weaver <mhw@netris.org>2015-07-15 23:19:27 -0400
commitbbd19615457ac6ced724489be80c6fbff972492e (patch)
tree8bb8d32d097556eaded5bea744795923aa94dd92 /gnu/packages/haskell.scm
parent385ae063c9826baf00ae47d7689f23af52bce753 (diff)
downloadguix-bbd19615457ac6ced724489be80c6fbff972492e.tar.gz
gnu: ghc: Don't pass --build=<triplet> to configure.
* gnu/packages/haskell.scm (ghc)[arguments]: Add #:build #f.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 75bbb24479..298caf108c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -116,6 +116,11 @@
        ;; gremlin) doesn't support it yet, so skip this phase.
        #:validate-runpath? #f
 
+       ;; Don't pass --build=<triplet>, because the configure script
+       ;; auto-detects slightly different triplets for --host and --target and
+       ;; then complains that they don't match.
+       #:build #f
+
        #:modules ((guix build gnu-build-system)
                   (guix build utils)
                   (guix build rpath)