summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:00 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:56 -0400
commit4fec5cdbf476067a2c2105121139857c024b547e (patch)
tree8ca7bb99631fd8204229e3d1e1832b7556e25a8e /gnu/packages/haskell.scm
parente1a56bb258728a1ece5cec378efd497fe1dfbc27 (diff)
downloadguix-4fec5cdbf476067a2c2105121139857c024b547e.tar.gz
gnu: Add ghc-directory.
* gnu/packages/haskell.scm (ghc-directory): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8ed658c17a..3fb847a4d2 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6909,4 +6909,25 @@ Colours can be blended and composed.  Various colour spaces are
 supported.  A module of colour names (\"Data.Colour.Names\") is provided.")
   (license license:expat)))
 
+(define-public ghc-directory
+  (package
+    (name "ghc-directory")
+    (version "1.2.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/directory/directory-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "0h3hrqskadmbigaxbz2k5xxjjjlmfaq2zdn2g7jh1wv9k6yrxraa"))))
+    (build-system haskell-build-system)
+    (home-page "http://hackage.haskell.org/package/directory")
+    (synopsis "Platform-agnostic library for filesystem operations")
+    (description
+     "This library provides a basic set of operations for manipulating
+files and directories in a portable way.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here