summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-11-30 12:14:27 +0100
committerLars-Dominik Braun <lars@6xq.net>2021-11-30 16:53:28 +0100
commitafc4945d44aeb6750b980abddbfda66f6ccb6b18 (patch)
tree7ac5789d5ebd3cd4b0e07f0475633e617b3c10ae /gnu/packages/haskell.scm
parentf22dfba53032c59fb260173143abf0e4e9a4f1e1 (diff)
downloadguix-afc4945d44aeb6750b980abddbfda66f6ccb6b18.tar.gz
gnu: ghc: Fix build on i686-linux.
* gnu/packages/haskell.scm (ghc-8.10)[arguments]<#:phases>: Disable
failing test.

Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 69a806e635..d3db023f08 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -22,6 +22,7 @@
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -711,12 +712,18 @@ interactive environment for the functional language Haskell.")
                  (("\\]\\), " all)
                   (string-append all "expect_broken(0)], ")))))
            ;; TODO: Turn this into an undconditional patch on the next rebuild.
-           ,@(if (string=? "i686-linux" (%current-system))
+           ,@(if (string-prefix? "i686" (or (%current-target-system)
+                                                  (%current-system)))
               '((add-after 'skip-more-tests 'skip-failing-tests-i686
                  (lambda _
                    (substitute* '("testsuite/tests/codeGen/should_compile/all.T")
                      (("(test\\('T15155l', )when\\(unregisterised\\(\\), skip\\)" all before)
-                      (string-append before "when(arch('i386'), skip)"))))))
+                      (string-append before "when(arch('i386'), skip)")))
+                   ;; Unexpected failures:
+                   ;;    quasiquotation/T14028.run  T14028 [bad stderr] (dyn)
+                   (substitute* '("testsuite/tests/quasiquotation/all.T")
+                     (("unless\\(config.have_ext_interp, skip\\),")
+                      "unless(config.have_ext_interp, skip), when(arch('i386'), skip),")))))
               '())))))
     (native-search-paths (list (search-path-specification
                                 (variable "GHC_PACKAGE_PATH")