summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-10-28 13:51:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-28 15:00:21 +0200
commit171b7290059831938657043ef4a4ddf41f4b9617 (patch)
tree73d66995dfc067bf6b4ef8b8bd2cac7ab6a0726c /gnu/packages/haskell.scm
parent65ad002ff10962f83bddf5070c22812f07b6437b (diff)
downloadguix-171b7290059831938657043ef4a4ddf41f4b9617.tar.gz
gnu: ghc-6.0: Adjust configuration.
* gnu/packages/haskell.scm (ghc-6.0)[arguments]: Pass --enable-src-tree-happy
option; remove --with-hc option because we use the same GHC for everything;
add --with-gcc option to embed absolute file name of GCC.
[native-inputs]: Remove unused python-2.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0caf741715..945aecd2b2 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -465,7 +465,8 @@ interactive environment for the functional language Haskell.")
                 (("ifdef SO_PEERCRED")
                  "ifdef SO_PEERCRED_NEVER"))
               (invoke "./configure"
-                      (string-append "--with-hc=" (which "ghc"))
+                      "--enable-src-tree-happy"
+                      (string-append "--with-gcc=" (which "gcc"))
                       (string-append "--prefix=" #$output)
                       (string-append "--build=" build)
                       (string-append "--host=" build)))))))
@@ -485,7 +486,6 @@ interactive environment for the functional language Haskell.")
                 ;; we want to use a more recent Perl we need to patch all
                 ;; expressions that require multi-line matching.  Hard to tell.
                 perl-5.6
-                python-2               ;for tests
                 ghc-4
                 gcc-2.95)))
     (home-page "https://www.haskell.org/ghc")