summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-05 14:22:28 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:14 +0200
commit9d1944a4939ae006b6f53c4203c49bc727c55dfd (patch)
treedca88af2c2be5a35d3d1cbd5987006114aaa9c3f /gnu/packages/haskell.scm
parent3c00bc13a5b78f0cfb240d60b4e283b1873b7ed9 (diff)
downloadguix-9d1944a4939ae006b6f53c4203c49bc727c55dfd.tar.gz
gnu: ghc-tasty: Update to 1.1.0.3.
* gnu/packages/haskell.scm (ghc-integer-logarithms-bootstrap,
ghc-scientific-bootstrap, ghc-attoparsec-bootstrap,
ghc-wcwidth-bootstrap): New variables to break a dependency cycle from
ghc-tasty.
* gnu/packages/haskell-check.scm (ghc-tasty): Update to 1.1.0.3.
[inputs]: Add ghc-wcwidth-bootstrap; remove ghc-regex-tdfa-rc.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5ea7ed8831..b50bf3d5d4 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2877,6 +2877,17 @@ aimed particularly at dealing efficiently with network protocols and
 complicated text/binary file formats.")
     (license license:bsd-3)))
 
+(define-public ghc-attoparsec-bootstrap
+  (package
+    (inherit ghc-attoparsec)
+    (name "ghc-attoparsec-bootstrap")
+    (arguments `(#:tests? #f))
+    (inputs
+     `(("ghc-scientific" ,ghc-scientific-bootstrap)
+       ("ghc-text" ,ghc-text)))
+    (native-inputs '())
+    (properties '(hidden? #t))))
+
 (define-public ghc-zip-archive
   (package
     (name "ghc-zip-archive")
@@ -5227,6 +5238,14 @@ occurrences of a substring (the first in case of overlaps) with another.")
 in migrated modules.")
     (license license:expat)))
 
+(define-public ghc-integer-logarithms-bootstrap
+  (package
+    (inherit ghc-integer-logarithms)
+    (name "ghc-integer-logarithms-bootstrap")
+    (arguments `(#:tests? #f))
+    (native-inputs '())
+    (properties '(hidden? #t))))
+
 (define-public ghc-scientific
   (package
     (name "ghc-scientific")
@@ -5264,6 +5283,19 @@ and space efficient.  They are represented using
 notation}.")
     (license license:bsd-3)))
 
+(define-public ghc-scientific-bootstrap
+  (package
+    (inherit ghc-scientific)
+    (name "ghc-scientific-bootstrap")
+    (arguments `(#:tests? #f))
+    (inputs
+     `(("ghc-integer-logarithms" ,ghc-integer-logarithms-bootstrap)
+       ("ghc-text" ,ghc-text)
+       ("ghc-hashable" ,ghc-hashable)
+       ("ghc-primitive" ,ghc-primitive)))
+    (native-inputs '())
+    (properties '(hidden? #t))))
+
 (define-public ghc-boxes
   (package
     (name "ghc-boxes")
@@ -10199,4 +10231,14 @@ The command line tool can compile a width table to Haskell code that assigns
 widths to the Char type.")
     (license license:bsd-3)))
 
+(define-public ghc-wcwidth-bootstrap
+  (package
+    (inherit ghc-wcwidth)
+    (name "ghc-wcwidth-bootstrap")
+    (inputs
+     `(("ghc-setlocale" ,ghc-setlocale)
+       ("ghc-utf8-string" ,ghc-utf8-string)
+       ("ghc-attoparsec" ,ghc-attoparsec-bootstrap)))
+    (properties '(hidden? #t))))
+
 ;;; haskell.scm ends here