summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-31 16:39:43 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-03-31 20:51:10 +0300
commit36a4366d79a310d05db0de2cf6d5bb3c5e861d4b (patch)
treec3968d05b86ac4f9d6cb70bbd34b94708ded305e /gnu/packages/haskell.scm
parentcd9ca20a5d54549db26d9780cbc7b282ec9f0001 (diff)
downloadguix-36a4366d79a310d05db0de2cf6d5bb3c5e861d4b.tar.gz
gnu: Fix descriptions to not use quotes.
* gnu/packages/admin.scm (wpa-supplicant-minimal, mingetty, di),
* gnu/packages/audio.scm (fil-plugins),
* gnu/packages/base.scm (make-ld-wrapper, make-glibc-locales),
* gnu/packages/bioinformatics.scm (r-samtools),
* gnu/packages/chez.scm (chez-mit),
* gnu/packages/commencement.scm (make-gcc-toolchain),
* gnu/packages/compression.scm (fastjar),
* gnu/packages/cran.scm (r-maps, r-rcpp),
* gnu/packages/databases.scm (sparql-query),
* gnu/packages/dunst.scm (dunst),
* gnu/packages/ftp.scm (ncftp),
* gnu/packages/gl.scm (freeglut),
* gnu/packages/haskell-check.scm (ghc-tasty-golden),
* gnu/packages/haskell.scm (ghc-case-insensitive, ghc-text,
ghc-haskell-src, ghc-syb, ghc-deepseq-generics, ghc-network-uri,
ghc-rerebase, ghc-zlib),
* gnu/packages/image.scm (jbig2dec),
* gnu/packages/kde-frameworks.scm (kinit, karchive),
* gnu/packages/linux.scm (wireless-tools, perf, module-init-tools, kbd),
* gnu/packages/lirc.scm (lirc),
* gnu/packages/lisp.scm (uglify-js),
* gnu/packages/mate.scm (mate-netbook),
* gnu/packages/microcom.scm (microcom),
* gnu/packages/music.scm (bristol),
* gnu/packages/networking.scm (perl-geo-ip),
* gnu/packages/patchutils.scm (patches),
* gnu/packages/perl-check.scm (perl-test-more-utf8),
* gnu/packages/perl.scm (perl-log-report-optional, perl-file-which,
perl-io-tty, perl-log-any, perl-digest-sha1, perl-class-load,
perl-regexp-common, perl-module-pluggable, perl-class-modifier),
* gnu/packages/python-xyz.scm (python-backports-abc, python-natsort),
* gnu/packages/samba.scm (iniparser),
* gnu/packages/search.scm (mlocate),
* gnu/packages/spice.scm (spice),
* gnu/packages/statistics.scm (r-dt, r-lubridate, r-estimability,
r-commonmark, r-digest, r-viridislite, r-stringr),
* gnu/packages/tex.scm (texlive-latex-changebar),
* gnu/packages/version-control.scm (subversion),
* gnu/packages/w3m.scm (w3m),
* gnu/packages/web.scm (perl-http-parser,
perl-plack-middleware-reverseproxy),
* gnu/packages/xorg.scm (xkeyboard-config, mkfontdir, xcursor-theme,
mkfontscale, xinit, font-alias)[description]: Use @code instead of quotes.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2a5ba2a706..a23dfe9ae6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1157,7 +1157,7 @@ them.")
     (synopsis
      "Support for manipulating Haskell source code")
     (description
-     "The 'haskell-src' package provides support for manipulating Haskell
+     "The @code{haskell-src} package provides support for manipulating Haskell
 source code.  The package provides a lexer, parser and pretty-printer, and a
 definition of a Haskell abstract syntax tree (AST).  Common uses of this
 package are to parse or generate Haskell 98 code.")
@@ -2360,11 +2360,11 @@ literals.")
      "Compression and decompression in the gzip and zlib formats")
     (description
      "This package provides a pure interface for compressing and decompressing
-streams of data represented as lazy 'ByteString's.  It uses the zlib C library
-so it has high performance.  It supports the 'zlib', 'gzip' and 'raw'
-compression formats.  It provides a convenient high level API suitable for
-most tasks and for the few cases where more control is needed it provides
-access to the full zlib feature set.")
+streams of data represented as lazy @code{ByteString}s.  It uses the zlib C
+library so it has high performance.  It supports the @code{zlib}, @code{gzip}
+and @code{raw} compression formats.  It provides a convenient high level API
+suitable for most tasks and for the few cases where more control is needed it
+provides access to the full zlib feature set.")
     (license license:bsd-3)))
 
 (define-public ghc-stm
@@ -2467,7 +2467,7 @@ are not exception safe and can be broken by @code{killThread}.")
      "An efficient packed, immutable Unicode text type (both strict and
 lazy), with a powerful loop fusion optimization framework.
 
-The 'Text' type represents Unicode character strings, in a time and
+The @code{Text} type represents Unicode character strings, in a time and
 space-efficient manner.  This package provides text processing
 capabilities that are optimized for performance critical use, both
 in terms of large data quantities and high speed.")
@@ -3800,10 +3800,10 @@ writing to stdout and other handles.")
      "https://github.com/basvandijk/case-insensitive")
     (synopsis "Case insensitive string comparison")
     (description
-     "The module 'Data.CaseInsensitive' provides the 'CI' type constructor
-which can be parameterised by a string-like type like: 'String', 'ByteString',
-'Text', etc..  Comparisons of values of the resulting type will be insensitive
-to cases.")
+     "The module @code{Data.CaseInsensitive} provides the @code{CI} type
+constructor which can be parameterised by a string-like type like:
+@code{String}, @code{ByteString}, @code{Text}, etc.  Comparisons of values of
+the resulting type will be insensitive to cases.")
     (license license:bsd-3)))
 
 (define-public ghc-syb
@@ -3830,7 +3830,7 @@ to cases.")
     (description "This package contains the generics system described in the
 /Scrap Your Boilerplate/ papers (see
 @uref{http://www.cs.uu.nl/wiki/GenericProgramming/SYB, the website}).  It
-defines the 'Data' class of types permitting folding and unfolding of
+defines the @code{Data} class of types permitting folding and unfolding of
 constructor applications, instances of this class for primitive types, and a
 variety of traversals.")
     (license license:bsd-3)))
@@ -4323,8 +4323,8 @@ interface.")
      "https://github.com/haskell/network-uri")
     (synopsis "Library for URI manipulation")
     (description "This package provides an URI manipulation interface.  In
-'network-2.6' the 'Network.URI' module was split off from the 'network'
-package into this package.")
+@code{network-2.6} the @code{Network.URI} module was split off from the
+@code{network} package into this package.")
     (license license:bsd-3)))
 
 (define-public ghc-ansi-terminal
@@ -5724,7 +5724,7 @@ using a simple box model.")
     (description
      "This package provides a @code{GHC.Generics}-based
 @code{Control.DeepSeq.Generics.genericRnf} function which can be used for
-providing an 'rnf' implementation.")
+providing an @code{rnf} implementation.")
     (license license:bsd-3)))
 
 (define-public ghc-string-qq
@@ -9430,7 +9430,7 @@ the community, with the missing features being added with pull-requests.")
      `(("ghc-rebase" ,ghc-rebase)))
     (home-page "https://github.com/nikita-volkov/rerebase")
     (synopsis "Reexports from ``base'' with many other standard libraries")
-    (description "A rich drop-in replacement for ``base''.  For details and
+    (description "A rich drop-in replacement for @code{base}.  For details and
 documentation please visit @uref{https://github.com/nikita-volkov/rerebase,
 the project's home page}.")
     (license license:expat)))