summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-06 16:49:53 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-06 18:14:52 +0200
commitb6bfa2cacfd3e8940098bc7c365337308d170300 (patch)
tree9b1c60aa6bb2dfd3c3622313d2c6bf081eda6ea2 /gnu/packages/haskell.scm
parent839415ecbcb3c614284a60d55eb4a51591153290 (diff)
downloadguix-b6bfa2cacfd3e8940098bc7c365337308d170300.tar.gz
gnu: Add ghc-indents.
* gnu/packages/haskell.scm (ghc-indents): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5a01eeceec..5e99ba2287 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2002,6 +2002,31 @@ isn't available, portable implementations are used.")
 both client and server code).")
     (license license:bsd-3)))
 
+(define-public ghc-indents
+  (package
+    (name "ghc-indents")
+    (version "0.3.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://hackage.haskell.org/package/indents/indents-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "16lz21bp9j14xilnq8yym22p3saxvc9fsgfcf5awn2a6i6n527xn"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-parsec" ,ghc-parsec)
+       ("ghc-concatenative" ,ghc-concatenative)
+       ("ghc-mtl" ,ghc-mtl)))
+    (home-page "http://patch-tag.com/r/salazar/indents")
+    (synopsis "Indentation sensitive parser-combinators for parsec")
+    (description
+     "This library provides functions for use in parsing indentation sensitive
+contexts.  It parses blocks of lines all indented to the same level as well as
+lines continued at an indented level below.")
+    (license license:bsd-3)))
+
 (define-public ghc-iproute
   (package
     (name "ghc-iproute")