summary refs log tree commit diff
path: root/gnu/packages/help2man.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@member.fsf.org>2014-04-06 20:30:37 -0400
committerDavid Thompson <dthompson@member.fsf.org>2014-04-08 20:42:08 -0400
commitcb3da2339a372bc71e2c678c826bbda0825f27e4 (patch)
tree85b84bb91b727ba3523ef971ca8398cf1149d5ec /gnu/packages/help2man.scm
parent67ca0a01bb3ffb425f9f6e278ac013987fe304c4 (diff)
downloadguix-cb3da2339a372bc71e2c678c826bbda0825f27e4.tar.gz
gnu: Move help2man package to (gnu packages man) module.
* gnu/packages/man.scm (help2man): New variable.
* gnu/packages/help2man.scm: Delete it.
* gnu/packages/cdrom.scm: Import (gnu packages man).
* gnu/packages/zile.scm: Import (gnu packages man).
* gnu-system.am (GNU_SYSTEM_MODULES): Delete 'gnu/packages/help2man.scm'.
Diffstat (limited to 'gnu/packages/help2man.scm')
-rw-r--r--gnu/packages/help2man.scm53
1 files changed, 0 insertions, 53 deletions
diff --git a/gnu/packages/help2man.scm b/gnu/packages/help2man.scm
deleted file mode 100644
index 9f3af7c9f5..0000000000
--- a/gnu/packages/help2man.scm
+++ /dev/null
@@ -1,53 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages help2man)
-  #:use-module (guix licenses)
-  #:use-module (guix download)
-  #:use-module (guix packages)
-  #:use-module (guix build-system gnu)
-  #:use-module (gnu packages perl))
-
-(define-public help2man
-  (package
-    (name "help2man")
-    (version "1.45.1")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "mirror://gnu/help2man/help2man-"
-                          version ".tar.xz"))
-      (sha256
-       (base32
-        "1hk7ciqinq7djdb7s94y3jxh06rp8i93bpjmg4r40cniws8wf3y7"))))
-    (build-system gnu-build-system)
-    (arguments `(;; There's no `check' target.
-                 #:tests? #f))
-    (inputs
-     `(("perl" ,perl)
-       ;; TODO: Add these optional dependencies.
-       ;; ("perl-LocaleGettext" ,perl-LocaleGettext)
-       ;; ("gettext" ,gettext)
-       ))
-    (home-page "http://www.gnu.org/software/help2man/")
-    (synopsis "Automatically generate man pages from program --help")
-    (description
-     "GNU help2man is a program that converts the output of standard
-\"--help\" and \"--version\" command-line arguments into a manual page
-automatically.")
-    (license gpl3+)))