summary refs log tree commit diff
path: root/gnu/packages/hexedit.scm
diff options
context:
space:
mode:
authorGábor Boskovits <boskovits@gmail.com>2017-06-23 18:16:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-06-26 16:35:55 +0200
commit24b91ebd2e78a103aee128e5e089b6d6bf339fd9 (patch)
treedd27be4956103dd92af5d36680df7b1d32afc13c /gnu/packages/hexedit.scm
parent7c028db5612de5ffde71a9a542d46047f53e2198 (diff)
downloadguix-24b91ebd2e78a103aee128e5e089b6d6bf339fd9.tar.gz
gnu: Add ht.
* gnu/packages/hexedit.scm (ht): New variable.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/hexedit.scm')
-rw-r--r--gnu/packages/hexedit.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/hexedit.scm b/gnu/packages/hexedit.scm
index d2aaec306b..8ddc0ffd4f 100644
--- a/gnu/packages/hexedit.scm
+++ b/gnu/packages/hexedit.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
+;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20,6 +21,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (gnu packages)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages ncurses)
   #:use-module (guix download)
   #:use-module (guix build-system gnu))
@@ -44,3 +46,28 @@ file can be a device as the file is read a piece at a time.  You can modify
 the file and search through it.")
     (home-page "http://rigaux.org/hexedit.html")
     (license license:gpl2+)))
+
+(define-public ht
+  (package
+    (name "ht")
+    (version "2.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://sourceforge.net/projects/hte/files/ht-source/"
+                    name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "0w2xnw3z9ws9qrdpb80q55h6ynhh3aziixcfn45x91bzrbifix9i"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("lzo" ,lzo)
+       ("ncurses" ,ncurses)))
+    (synopsis "Viewer, editor, and analyzer for executable binaries")
+    (description
+     "ht is a terminal-based program to view, edit, and analyze any file, but
+with a special focus on executable binaries.  Its goal is to combine the
+low-level functionality of a debugger with the usability of an @dfn{Integrated
+Development Environment} (IDE).")
+    (home-page "http://hte.sourceforge.net/")
+    (license license:gpl2)))